Seems to stall on Android/Chrome

Technical Support
  • I seem to be hit a number of pages on my test site on where the progress indicator goes to about 70% and stalls on Android Chrome (very new and this site seems to work fine)

    I do have the desktop notifications plugin active. Am also running the master branch with a slightly edited persona theme for adsense.

    Any obvious issues that might be causing the stalls?

  • @shri Try disabling plugins one-by-one and seeing if that clears up the stalling issue. It could be a plugin issue.

  • @shri also if you've got adb and debugging drivers plugged in and enabled (if you don't know what I'm talking about now, stop reading) then you can use chrome://inspect in the address bar to be able to see the console and elements for the phone's web view.

  • @Drew-Llewellyn that is indeed something I am going to try today. Was hoping to eliminate any obvious mistakes before breaking out the debugger. 🙂

  • Still no where near a desktop, but did try one thing. Logged into the forum as a new user and no delays. Logged back in as admin and it stalls.

    Explains why I don't see this problem here.

    Same phone and same signal / location.

    Wonder if some extra webslckets are timing out for me when logged in as admin.

    Will test further and report back.

    @julian can you reply to my email on sales?

  • This is what I get in the Chrome timeline when I inspect - which, while it is accurate (600ms) that /api request stays pending for 10-60 seconds before it goes through.

    Server logs show that the response is sent out in < 100ms so 600ms over mobile seems reasonable.


    The culprit may be an adsense code block that I have in the widget area. Removed it and things seem to be faster. Need to nail this down and get it to fail / work consistently. (The init code is in the header via the custom header / css config.

     <div style="text-align: center; height: 280px; min-width: 300px; max-width: 336px; margin: 10px auto; padding-bottom: 10px;">
     <!-- 2015 - NewsFora V3-->
    <ins class="adsbygoogle"
     style="display: block;"
    (adsbygoogle = window.adsbygoogle || []).push({});
  • Ok, I can confirm that it is the above adsense code which was put into an HTML widget which causes a stall.

    Weird though that is very significant on a mobile load (3-5 seconds and some time a minute plus).

    Leaving it on if someone can take a look and see what could be causing this problem on an Android / Chrome combo (both over WiFi and Mobile - eliminates the possibility that the mobile carrier is causing a delay).

    Incase it matters -

    • ./nodebb dev does not return any more info.
    • nginx is sending out the response within the 200ms range. Will break out wireshark over the next day or two and check if it is indeed being received by the mobile device.
    • Theme independent - tested on persona and lavender. (Did this as the spinner from njprogress.js was active on persona while waiting)


  • And one last bit of info - seems to be ok on Firefox on Android. Not on Chrome on Android.

  • @psychobunny - could you look at this issue? I suspect that the ad block (more likely the javascript part of the block) is causing some server side or client side rendering / blocking?

    Theoretically, seems impossible as the API call just sends out JSON ... but I suspect something after the JSON data is returned causes a stall or timeout on the android client.

    Clueless on how to debug further.

  • For me, after I think 5 loads I get this message and the ads disappear:

    but, the site works as normal for me (just the ads aren't appearing)

  • Tried on chrome, this is the result

    The forum continues to work as normal, but ad doesn't appear


    is causing some server side or client side rendering / blocking?

    More importantly, I'm not getting an issue like this. The only issue is that the sidebar is empty, for me

Suggested Topics

  • 0 Votes
    3 Posts

    Thank you.

    I've trying to isolate a few things now:


    I can't find a way to colorize this white strip.


    The font color for the "chat, quote, and reply" so it's easier to see.


    And then the widgets (header/side bar) and button bar (I don't know what it's called).

    I've tried looking up the classes but they haven't provided a result that fixes it.

    Again, all help is greatly appreciated.

  • 1 Votes
    1 Posts

    Aside from building some pretty if/else blocks, is there any way to specify a distinct template for a particular forum or subforum?

  • 0 Votes
    2 Posts

    ./nodebb reset just disables all plugins.

    Use nodebb without a command to see all commands. ./nodebb

    Welcome to NodeBB Usage: ./nodebb {start|stop|reload|restart|log|setup|reset|upgrade|dev} start Start the NodeBB server stop Stops the NodeBB server reload Restarts NodeBB restart Restarts NodeBB log Opens the logging interface (useful for debugging) setup Runs the NodeBB setup script reset Disables all plugins, restores the default theme. activate Activate a plugin on start up. plugins List all plugins that have been installed. upgrade Run NodeBB upgrade scripts, ensure packages are up-to-date dev Start NodeBB in interactive development mode watch Start NodeBB in development mode and watch for changes
  • 0 Votes
    2 Posts

    Something went wrong with setting up connection to MongoDB. Could you please provide some more information about your configuration?

  • 0 Votes
    31 Posts

    Shouldn't this request be directed to Taptalk Inc? They seem to charge both the app user and the forum maintainer for "pro" features.

    As this is an open source project, they're free to provide a NodeBB taptalk plugin and earn more money 😉