Error on setup + Domain clarification

Technical Support
  • Well, first and foremost, I'm new to this whole thing. I have no background on this type of thing, so if you are able to help me, give it to me like a 5th grader.

    Moving on, I purchased a server on Digital Ocean and installed nodebb. It worked absolutely fine. Then I wanted to use my domain instead of the IP address. After Googling, I found out that I needed to use nginx. Without thinking, I installed nginx in the same directory as nodebb which just made everything blow up on my end. So I wiped the droplet to start over. Since then, I've had an issue on reinstalling nodebb as it continuously give me this error:


    For reference, I used this guide for setup

    I've read this thread in regards to the issue, the only thing is that his error is "sadd" and not "zadd" so I'm not sure of the difference it makes there.

    Secondly, when installing nginx, I'm assuming I need to make a directory for it and install it into there correct? I've created an A Name on my domains end to point to the IP address, shown below:


    On top of that, I know nginx is used to listen for the command my domain is sending and then I'm supposed to create a DNS record (idr the reason why) but just making sure I'm going in the right direction.

  • Hey! There's a guide for setting up NodeBB with nginx here. As for your error, perhaps try downloading the latest stable (0.7.x) instead of using the master branch (which I assume you're using)? You can do that through git by running
    git clone -b v0.7.x nodebb

    If you don't have git (which I'd recommend installing), you can download 0.7.x through GitHub, by following this link.

    Finally, make sure redis is fully updated. Check your version with redis-server --version, and make sure that it's version 2.8.9 or greater. If it isn't, there are various guides around which should help you update.

    Hope this helps!

  • @itsCrafted I plan on using that guide, but still for clarification, I should be installing it in its own directory correct?

    As for the latest installation, the guide put me through to update to the latest version (I wish I could recall what it was :C ). As well, the guide told me to install git, so I'm pretty sure I've done what you've said.

  • @Victoryoftheppl How are you installing nginx? If you're using a package manager, it should handle the installation directory etc by itself. NodeBB can be installed anywhere, really. I recommend using your home folder (cd ~).

    On my distro (Ubuntu), nginx is installed in /etc/nginx, and I installed it using sudo apt-get install nginx.

  • @itsCrafted As stated in the OP, I installed nginx in the same directory (folder maybe?) as nodebb which caused issues. I'm using putty to do what's needed to manage everything. Not to be rude, but in terms on the nodebb installation, I would suggest going through the setup guide I linked. It'll let you know all the steps I've done so you don't have to repeat 🙂

    This overall isn't helping with the main issue in regards to the error I'm getting. nginx is moot until I figure the error out ^_^

  • Can anyone please help me? I really like the software and I have a project that I'm trying to get set up that I'm extremely passionate about =/

    I tried using these instructions as well, and tell me the nodejs-legacy can't be found.

  • @julian maybe you can help?

  • @Victoryoftheppl To install nginx,

    $ sudo apt-get install nginx

    That's all 🙂

  • @julian Hi! so I got everything going. The forum was up for like...2 minutes on not it's showing bad gateway :C

Suggested Topics

  • Socket-IO Redis error

    Solved Technical Support
    0 Votes
    6 Posts

    @baris I'm really trying to stick to actual releases (looking at github it doesn't look like 1.17.1 has been officially blessed yet). However, staying on v1.17.0 and bumping the and versions seems to have done the trick!

  • 0 Votes
    1 Posts

    Hi Devs,

    I am running the latest nodebb master, and updated to the latest redactor-composer.

    I tried to upload a file using redactor, but it did not work, and no error message was posted. With further digging I found that the file was too big (higher than the predefined value in the admin page).
    Is there a way to catch and display errors from nodebb callback routed into the Redactor plugin?

    Minor issue, I see that when @media width>1000 Redactor is full page, but the topic title placeholder disappears. Further research identified that the div above it has "display = flex". Unsettling that brings back the title placeholder.


  • 1 Votes
    7 Posts

    It was rather trivial to add the error message, here is how:

    in uglify-js module, added a error reporting log to the file lib\parse.js in following method:

    function js_error(message, filename, line, col, pos) { console.log(message, filename, line, col, pos); throw new JS_Parse_Error(message, filename, line, col, pos); };

    Looks like the error handling of fault barrier doesn't do what it supposed to.

    @PitaJ Thank again for your help.

  • Redis error

    Technical Support
    0 Votes
    2 Posts

    That's not a Redis error but it does appear to be a bug. Open an issue on Github.

  • Redis Error

    Technical Support
    0 Votes
    4 Posts

    Yeah, it was a RAM issue. Upgraded the server and all is well now.