NodeBB Install on DigitalOcean Not Working



  • I have setup a new droplet on D.O. (Ubuntu) and installed all the requirements via the help from the docs and from here

    I dumped my dump.rdb file into the root folder of nodebb and configured it so /etc/redis/redis.conf looks for the dump.rdb there.

    Whenever I run redis-server it works with the normal 'warning no config redis.conf found'.

    However, when I add redis-server /etc/redis/redis.conf it gives me a blank line and does not seem to work.

    I setup nodebb using ./nodebb setup and added the IP provided by D.O. in the url settings, and defaulted everything else.

    But, when going to the IP, it does not load at all.

    Any help would be great

    I did ./nodebb start and redis-server /etc/redis/redis.conf to no success

    Edit: I zipped up my local files and deployed it onto the Ubuntu server. Is this a proper way to do it? I have not changed any core codes at all.


  • Admin

    Hm, there shouldn't really be any need to interact with Redis at all during installation.

    A basic DO droplet can set up Redis just by running sudo apt-get install redis-server -y

    Then it is automatically started, reads the default config file at /etc/redis/redis.conf, and loads the database at /var/lib/redis/dump.rdb.

    No need to move the database anywhere, really.



  • @julian Thanks Julian, I wasn't able to stop the redis-server manually for (redis-cli shutdown?). I changed the path to where my current dump.rdb file was in /etc/redis/redis.conf but for some reason I could not reload it with redis-server /etc/redis/redis.conf

    I ended up uninstalling redis-server via sudo apt-get remove redis-server and reinstalled it again via sudo apt-get install redis-server and it pointed to my new dump.rdb file.

    I think I'm slowly getting the hang of this!



  • @julian Now I am unable to access the login page I receive "Forbidden" whenever I log in as admin. How would I change this?

    Also, my assets are not displaying properly as well?

    Everything works fine on my local.

    image.png


  • Admin

    I think your url value in config.json is not set correctly.

    How are you accessing the forum? It should be the same address as that, with the http:// and everything.



  • @julian Odd, everything seems to be in working order now. My config.json was pointing to the IP provided by D.O. and I assigned it as http://<IP HERE>:4567



  • I have installed nodebb on digitalocean. Installed successrfully . But unable to get it via any url using broswer..



  • @Arindam-sarkar remember: you need open firewall config for default nodebb port


    Assuming you kept the default port setting, you need to allow it through the firewall.
    firewall-cmd --zone=public --add-port=4567/tcp --permanent
    firewall-cmd --reload


Log in to reply
 

Looks like your connection to NodeBB was lost, please wait while we try to reconnect.