Composer Errors



  • One of my users on my forum ( there's only 10 people)
    got the following error:

    [Error] Error: Unable to load template: composer (Not Found)
    error (nodebb.min.js, line 15)
    u (nodebb.min.js, line 1)
    fireWith (nodebb.min.js, line 1)
    T (nodebb.min.js, line 3)
    n (nodebb.min.js, line 3)
    [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (composer.tpl, line 0)

    and I'm trying to make sense of it , is there something I could do to fix it? It seems to have something to do with a recent update of the forum. But I'm not experiencing the error , one of my users are..... which makes it even harder to solve.


  • Admin Staff

    If it works fine for you and not for them it's probably because they have a cached version of the javascript. Tell them to clear their browser cache and try again.



  • I did some investigating , cleared my own DNS / cache on my computer and I also came up with the same error that one of my users did , so it seems that it's a more complex then I thought.

    I also disabled all my plugins to see if there was any interference....and the problem is still there.


  • Admin Staff

    Ahh for the composer to work you need the plugin nodebb-plugin-composer-default make sure thats installed and activated and you are on latest master.



  • It's still not working. I enabled it like you said. Previously , when it wasn't working for one of my users , that was when all the plugins were all enabled too.

    edit: I renabled all plugins except for the lavender theme , and it seems to be working now - tested it on IE and chrome.

    I think the lavender theme has some code that's conflicting with the composer , since it got updated recently.


Log in to reply
 

Suggested Topics

| |