Solved New installation missing views

  • Hey there,

    I just started playing around with NodeBB and so far I am impressed with how easy it is to set up.

    However, even though I managed to follow the simple installation process and start NodeBB (using ./nodebb start), all I got was a blank home page.


    I configured my installation to work with MongoDB. I thought that may be causing some weird issues so I tried with Redis too. The result was the same. I even tried installing it on Ubuntu 14.04, Windows 8.1 and even on a Vagrant box (ubuntu/trust64).

    I am kinda confused. The installation seems to have went correctly, after all I can start the app.

    Am I missing a theme or something, or am I just stupid and have missed something? ๐Ÿ˜ƒ

    P.S. I followed the official documentation in order to install.

  • Do you have any errors in your browser ? Ctrl+Shift+J for Chrome.

  • Community Rep

    Cmd+alt+i for Chrome on mac ๐Ÿ™‚

  • @leksar No errors in chrome's console. On firefox, it seems to occur randomly, but I sometimes get the following error
    The connection to ws:// was interrupted while the page was loading.

    I checked the partials to make sure everything is there. It seems like the view cannot be rendered properly.
    I even tried reinstalling the rendering engine module with no success.

    I forgot to mention that the /register page gets rendered. It looks like this.


  • Community Rep

    Is there anything in your console running Nodebb or the redis server? Could you describe the exact steps you took to set up?

  • @BDHarrington7 Thanks for your help, I managed to get it up and running yesterday. The problem turned out to be npm. For some reason it never completely downloaded all modules.

    I managed to figure that out by running the nodebb app with nodemon. When I ran it I saw an error get thrown, which wasn't in the nodebb log.

    Simply put, always check your npm modules! Dependencies go deep and sometimes may get messy.



  • Community Rep

    Nice! Out of curiosity, what was the error thrown?

  • @BDHarrington7 There, I deleted the connect-mongo module to replicate the problem that I had.

  • I have that problem now ๐Ÿ˜ž

  • Community Rep

    @Darwin sometimes npm will run out of memory when building the dependency tree. How much RAM are you running on?

  • @Bri on server 512mb. Digitalocean... but it also happy on local machine.. now Iยดam starting from scratch ๐Ÿ™‚

  • Community Rep

    Yeah, I've had trouble installing NodeBB on a 512Mb machine. You can either increase to 1GB, or turning on swap might help.

  • GNU/Linux Admin

    seconding swap. A 512mb droplet will run out of memory when installing dependencies for NodeBB..

Suggested Topics

| | | |