Non-latin Search on NodeBB

Technical Support

Suggested Topics

  • 0 Votes
    6 Posts

    @ocisp87 any time

  • 0 Votes
    4 Posts

    @yariplus said in After changed ip get badway 502 error and nodebb does not start:

    Your forum may work, but has no security, anyone can login and delete/steal the database. You need to setup your redis so that it has a password, and that it restricts access to localhost.

    @yariplus thank you so much.

  • 0 Votes
    1 Posts

    Prelude: Last year, ran nodeBB under a root user just fine. many months later, system crashed and had to wipe the server. This time on installation, on a new server, ran into various errors. Was told not to run nodeBB under the root user, so --

    Creating a new user, and pulling and installing a different instance of nodeBB I am now running into errors with npm install (even using the global command) and generally overall.

    Is this still due to file permission issues regarding the first time setting up nodeBB on the new server? Or is something else to blame?

    When utilizing nodeBB on the new user, npm gives errors such as not finding modules (even tried removing node_modules directory and doing npm -g install), and when I do get the npm install to not crash, running any ./nodebb command still gives errors.

    Does anyone know the issue at hand? I'm thinking of wiping the server, and giving it one more try via not using root from the start to see if the errors can be avoided altogether - if not I may just move on to a different forum system.

    Thanks in advance!

  • NodeBB Websocket Question

    Solved Technical Support
    1 Votes
    3 Posts

    On Concurrent WebSockets connections...

    A Lightstreamer plugin would be interesting to see. Likely overkill in most situations though. Carving out the websockets demand on resources could be good in large deployments; lightstreamer server. With Comet functionality, one could hook into big data analytic platforms.

  • 0 Votes
    3 Posts

    @julian have you ever used copyDatabase with an already existing destination? For me it just fails with

    "errmsg": "failed to create collection "nodebb_testing.sessions": collection already exists"

    which sounds as if it would expect an empty database or at least one without duplicate collections.
    If this won't work I doubt that there is a readymade command to help me achieve my goal.