Login attempts fail on Linux after install but work on Windows.

Technical Support
  • Hi,

    After installing nodebb on my Ubuntu VM with the latest stable software (0.6.1), I'm unable to login or register new accounts. I'm running Ubuntu 14.04.2 LTS, with Node.js v0v0.10.38, latest npm. No luck with Mongo or Redis (both latest versions) on Linux. Setting up on Windows works flawlessly but I kinda need this to run on Linux. I've been searching around the forums here and online but found no solution yet. I did read about an AJAX timeout somewhere but I can't see where to adjust it. Below is a screenshot of what I'm getting. Any help much appreciated.Screenshot_2015-05-11-00-51-35.png


    This program comes with ABSOLUTELY NO WARRANTY.                              This is free software, and you are welcome to redistribute it under certain conditions.
    For the full license, please visit: http://www.gnu.org/copyleft/gpl.html
    Clustering enabled: Spinning up 1 process(es).
    11/5 00:49 [4130] - info: Time: Mon May 11 2015 00:49:07 GMT+1000 (AEST)
    11/5 00:49 [4130] - info: Initializing NodeBB v0.6.1
    11/5 00:49 [4130] - info: NodeBB is now listening on:
    11/5 00:50 [4130] - info: NodeBB Ready
  • Are you connecting directly to nodebb or are you using apache/nginx to proxy the connection?

  • Hello,

    I get similiar problem on using MongoDB. Login panel does not appear on MongoDB but appears on Redis. I am using Windows Server 2008 R2. I don't understand why.

  • @Ali Sounds like nodebb can't connect to mongo. Have you looked at the nodebb logs?

  • @KingCat This is both directly and through an Nginx 1.8.0 proxy. Also different browsers and Chrome's incognito on different devices (including my PC) give the same result.

  • Ok, erasing everything and switch to GIT branch 0.5.x did the trick. I'm currently using v0.5.7 with Redis and all is well. There's definitely something funny about v0.6.1 on Ubuntu that does not login. Haven't upgraded yet but not sure if I should. Any ideas anyone. @julian

  • Annoying... v0.6.x shouldn't magically break because it's a stable branch, but it has been known to happen, since the dependencies for databases are not locked down.

    I'll give it a shot today.

  • @julian Any luck with this? I tried upgrading last night and bricked nodeBB again.

  • Solved: upgrade to NodeBB v0.7.0.

Suggested Topics

  • 0 Votes
    26 Posts

    No it goes in library.js since it's a server side hook. And you need to add the corresponding entry in plugin.json.

    // library.js myPlugin.filterMiddlewareRender = async (hookData) => { hookData.templateData.user = await user.getUserData(hookData.req.uid); return hookData; }; //plugin.json "hooks": { "filter:middleware.render": "filterMiddlewareRender" ... }
  • 0 Votes
    3 Posts

    I was able to install it by following the instructions from here: https://products.containerize.com/discussion-forum/nodebb
    I already have node.js installed on my computer. I did not install redis or nginx.
    I have a mac, so on Terminal, after I created a directory called "nodebb", I skipped the first few lines of the instructions, and just pointed to the directory I created, by using the "cd" command. I then created another directory called NodeBB inside the nodebb directory. You may skip creating two directories and just create a directory called "NodeBB". I pointed to this directory by using the cd command.
    Then this line
    "git clone -b v1.15.x https://github.com/NodeBB/NodeBB.git ."
    was the key for me.
    After I typed that, nodebb was cloned to the directory.
    Then I ran "./nodebb setup".
    I used mongo for the database.
    When prompted, I pasted the connection string that I got from mongodb's site. I substituted "nodebb" for the database part in the string. (I set up mongodb (Cloud Atlas) beforehand). The instructions that come up on Terminal will tell you to call your database "nodebb".
    After that step, the program ran automatically and installed the files. It asked me to put in the username and password for mongodb and it also asked me to choose a name for admin and password. You might have to wait a while as it pauses for a long time after "Confirm Password". I thought there was some problem and was tempted to abort the operation, as it was taking a long time, but it did come up with further instructions after a while.
    I typed "./nodebb start" when the setup finished and then went to "localhost:4567", and this time, I was able to see a normal board, and could log in as admin.
    I write this follow-up in case another mac user has trouble installing nodebb. In the end, setup was pretty straightforward and did not involve a lot of steps. My OS is High Sierra.
    The instructions, including the ones for Linux, at the official nodebb site did not work for me.

  • 0 Votes
    6 Posts

    I don't know if you need to get rid of the domain folder, but you do need to set up the reverse proxy.

  • 0 Votes
    4 Posts

    @pitaj said:

    @Master-Antonio add your domain in the config.json file which sits in the NodeBB main directory.

    Did, but don't work.

  • 0 Votes
    5 Posts

    As far as I know, the code for blog comments has been reworked, and should be working fine for Wordpress 🙂