NodeBB Setup Aborted - help with install parameters

Technical Support
  • Hello,

    I'm looking for a clarification on the install steps if someone could fill me in ...

    The first thing that is not clear to me ... the URL used to access this NodeBB ... I'm installing on a server and not a local machine. So I'm sure I can't accept the default localhost entry. I have set the nodebb directory in the root url - here's an example if I were to type the URL out in a browser ...

    When I typed the command ./nodebb setup it was from within the /nodebb directory. With this example, would the URL used to access NodeBB be http// (or do I have to indicate the default port as well?)

    The next spot I am confused with is regarding the Redis database, I'm assuming the Redis database was installed with the first step in "installing the software stack" but I don't know what the Host IP or address would be other than the IP address of my server. If it's the later, then how would I setup more instances of NodeBB. My first attempt I entered my server IP thinking it would just connect via the default port, but I'm not sure that worked. So the result of the command line that I am posting below is when I just used the default IP (I know it's used for local machines, but didn't know what else to use)

    Here's the results I have in the console when trying to run the setup. I used the default values except the URL to access (I have replace actual path and url's with dummy info for this post)

    $ ./nodebb setup
    24/4 17:58 [15355] - info: NodeBB v0.6.1 Copyright (C) 2013-2014 NodeBB Inc.
    24/4 17:58 [15355] - info: This program comes with ABSOLUTELY NO WARRANTY.
    24/4 17:58 [15355] - info: This is free software, and you are welcome to redistribute it under certain conditions.
    24/4 17:58 [15355] - info: 
    24/4 17:58 [15355] - info: NodeBB Setup Triggered via Command Line
    24/4 17:58 [15355] - info: Welcome to NodeBB!
    24/4 17:58 [15355] - info: This looks like a new installation, so you'll have to answer a few questions about your environment before we can proceed.
    24/4 17:58 [15355] - info: Press enter to accept the default setting (shown in brackets).
    URL used to access this NodeBB (http://localhost:4567)
    Please enter a NodeBB secret (e40b69a0-65ee-4822-8596-63c8471635e9) 
    Which database to use (redis) 
    24/4 17:59 [15355] - info: Now configuring redis database:
    Host IP or address of your Redis instance ( 
    Host port of your Redis instance (6379) 
    Password of your Redis database 
    Which database to use (0..n) (0) 
    24/4 17:59 [15355] - error: Error saving server configuration! EACCES, open '/myserverpath/nodebb/config.json'
    24/4 17:59 [15355] - warn: NodeBB Setup Aborted. EACCES, open '/myserverpath/nodebb/config.json'

    Any help is much appreciated ... Pops

  • Just curious if this may have any impact or possibly the reason my install is aborting.

    When I ran the first step to install the dependencies this line was showing as the last line

    N: Ignoring file '20auto-upgrades.ucf-dist' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension

    I'm stumped at this point, I don't understand why the setup is being aborted. I even checked to see if the Redis database was installed and it is, I even sent the command to make sure it was running, it is. When I run the command redis-cli ping I get the expected PONG in return.

    Short of getting the clarification as to how the above information should be entered, I'm at a loss

    I'm going to look up information on Redis to see if I can manually set up a database so I have valid information to enter on the NodeBB setup.

    Am I going in the right direction at least ???

  • @PopsRocker said:

    error: Error saving server configuration! EACCES, open '/myserverpath/nodebb/config.json'

    The error message is telling you that it can't access/save the file. Make sure the user you are running the commands has the proper permissions.

  • With some more digging, I started wondering if there was something regarding the URL.

    I'm using ServerPilot as a control panel for my dedicated server which is the same control panel as is used with DigitalOcean, in fact, ServerPilot was designed for DigitalOcean. I have to assume the DigtalOcean VPS's are set up much the same way as my dedicated server is set up.

    Nginx is configured as a proxy in front of Apache, therefore I'm not sure how I could use any of the guides found here - because none of them are setup in a way that matches how ServerPilot uses Nginx ... or I may be missing this completely, but I hope someone from the dev team will see my issue and understand what is going on, after all, I'm sure there's someone who is familiar with how DigitalOcean sets up NodeBB

    ... Pops

  • @baris said:

    The error message is telling you that it can't access/save the file. Make sure the user you are running the commands has the proper permissions.

    I wondered that too, I was using a user I specifically created for this task in order to not use the root user as I thought it was not a good practice to do. Especially since the instructions indicate a sudo user. Usually I can figure out permission issues, but for some reason I have not been able to solve this one. The installation does get further when using the root user, so there is definitely a permission issue.

    The error I get now is related to the connection of the Redis database. I get a connection refused error when using the IP of the server.

    The abort error shows the IP address and default port number so I have no idea how to connect the database.

    Here's the latest console information ...

    [email protected] node_modules/connect-redis
    ā””ā”€ā”€ [email protected] ([email protected])
    25/4 19:08 [21628] - info: Populating database with default configs, if not already set...
    25/4 19:08 [21628] - error: Error: Redis connection to myserverIP:6379 failed - connect ECONNREFUSED
        at RedisClient.flush_and_error (/mydomainpath/nodebb/node_modules/redis/index.js:142:13)
        at RedisClient.on_error (/mydomainpath/nodebb/node_modules/redis/index.js:180:10)
        at Socket.<anonymous> (/mydomainpath/nodebb/node_modules/redis/index.js:95:14)
        at Socket.EventEmitter.emit (events.js:95:17)
        at net.js:441:14
        at process._tickCallback (node.js:415:13)
    25/4 19:08 [21628] - warn: NodeBB Setup Aborted. Redis connection to myserverIP:6379 failed - connect ECONNREFUSED

    Thanks ... Pops

Suggested Topics