Emailer via local SMTP and SSL/TLS



  • The local emailer plugins don't work out of the box with SSL/TLS. But it's possible, because those plugins share the same settings. This workaround worked with my installation. Hope it will help you too.

    Rem: If you've tried to setup the local emailer plugin, it will be better if you reset the local emailer settings in the database before you continue.

    1. Go to your NodeBB directory. Install the plugins.
        $ cd ~/nodebb
        $ npm install nodebb-plugin-emailer-ssl-smtp
        $ npm install nodebb-plugin-emailer-local
    
    1. Remove line 39 in the file "node_modules/nodebb-plugin-emailer-ssl-smtp/templates/admin/emailers/smtpssl.tpl".
    	<!-- If you're using an older commit, use type="text". Or pulling the up-to-date version would be even better ;) -->
    

    Or patch it like here: Source

    1. Open the log
        $ ./nodebb log
    
    1. Open the Homepage of your NodeBB-Forum. Login as Admin and open the Admin Panel.

    2. Open ACP > EXTEND > Plugins
      Activate nodebb-plugin-emailer-ssl-smtp
      Don't activate nodebb-plugin-emailer-local
      Bildschirmfoto 2015-04-21 um 14.00.08.png
      Reload Forum
      Reload Page

    3. Open ACP > INSTALLED PLUGINS > Emailer (Local) Smtp SSL
      Fill out the Settings
      Bildschirmfoto 2015-04-21 um 13.55.02.png
      Click "Save"-Button

    4. Open ACP > SETTINGS > Email
      Enter the Email-Address. (If you forget it, you mails will be end up as spam)
      Bildschirmfoto 2015-04-21 um 13.43.51.png
      Click "Save Changes"-Button
      Click "Send Test Mail"-Button
      If the log shows this, continue:

    22/4 13:05 [10871] - warn: [emailer.smtp] Unable to send `test` email to uid 1!!
    22/4 13:05 [10871] - warn: [emailer.smtp] Unable to send `test` email to uid 1!!
    22/4 13:05 [10871] - warn: [emailer.smtp] Unable to send `test` email to uid 1!!
    
    1. Open ACP > EXTEND > Plugins
      Dectivate nodebb-plugin-emailer-ssl-smtp
      Activate nodebb-plugin-emailer-local
      Bildschirmfoto 2015-04-21 um 14.00.23.png
      Reload Forum
      Reload Page

    2. Open ACP > SETTINGS > Email
      Click "Send Test Mail"-Button
      Watch log for:

    22/4 13:09 [10871] - info: [emailer.smtp] Sent `test` email to uid 1
    22/4 13:09 [10871] - info: [emailer.smtp] Sent `test` email to uid 1
    22/4 13:09 [10871] - info: [emailer.smtp] Sent `test` email to uid 1
    

    Done.

    Kudos to @ahwayakchih. He was big help to get this running. 👍


  • Swedes

    Nice workaround ;)

    I hope this plugin will be patched soon to work native without the need of a workaround :) But great job



  • @Mikael
    Thank you. ☺

    You can also vote up the topic in the upper right. :D

    Bildschirmfoto 2015-04-22 um 15.05.13.png


  • Swedes

    Sure, why not ;) From sweden? Check out this



  • @Mikael said:

    From sweden?

    No. From Dshermanie. 😉


  • Swedes

    The built in emailer works great now with google ;) <3



  • @Hägar said in Emailer via local SMTP and SSL/TLS:

    nodebb-plugin-emailer-ssl-smtp

    Internal Error. Oops! Looks like something went wrong! /admin/emailers/smtpssl Failed to lookup view "admin/emailers/smtpssl" in views directory "/home/nodebb/nodebb/build/public/templates"

    :(




Looks like your connection to NodeBB was lost, please wait while we try to reconnect.