• Problem seems to be solved. I had no categories that were configured to be seen by guests: added one and seems to work

  • I am now getting this error. It started yesterday. When going to home page.... no matter who is loggin in. When trying to move or delete posts just greyed out pop-ups with no focus. My forum is broken....


  • Here is what I am getting from the nodebb console...2015-04-22 10_19_41- - Remote Desktop Connection.png

  • GNU/Linux Admin


    Can you please provide the following information to help us debug as well?

    1. Server or client operating system (if applicable)
    2. NodeBB version and hash
      • To get the hash, run git rev-parse HEAD from the root of your NodeBB folder
    3. If applicable, theme versions
      • npm ls nodebb-theme-persona


  • @julian hash= 5501c0c759f44fcf0447f66ba1a7d2088ec0f8bb

    D:\NodeBB>npm ls nodebb-theme-persona
    nodebb@0.7.0-dev D:\NodeBB
    └── nodebb-theme-persona@0.1.30 extraneous
    npm ERR! extraneous: nodebb-theme-persona@0.1.30 D:\NodeBB\node_modules\nodebb-t
    npm ERR! not ok code 0

    Windows Server 2008.

    FYI...been having lots of problems with Categories and Groups.

  • NodeBB

    Does your config.json have a redis password? Also is auth enabled for redis?

  • @baris Yes the config.json does have a password... but I do not believe that auth is turned on in the redis config ( I will turn it on). Never was much of an issue. This problem went full retard yesterday, but I saw hints of it on and off a few days before. I would get random errors along the "/" issue, but Nodebb recovered.

  • FYI... I just did a new nodebb install and pointed to the same Redis database. Same issue. Everything works fine except the 'home' page.


  • FYI.... I just went through the Lavender, and Vanilla themes. When first initialized to a different theme, and the first click on Home, brought-up the home page. After that just the error. I don't know what to do...but my forum is broken. I have put so much time into this project. I do not want to start from scratch with a clean database ... losing all the posts and work. Any help will be greatly appreciated.


  • Admin

    How about plugins, have you disabled them all?

  • Just to put this issue to bed. I trashed the old forum. Installed new. New git clone... new database. Problem solved.


Suggested Topics

| |