Wrong message shown for invalid username and password



  • This is the screen shown when invalid username and password was input.
    Bug.jpg


  • Swedes

    Plz state what version! Latest or 0.6.x ?



  • @Mikael
    Its currently on v0.7



  • You want to install it again. This time with all required npm modules installed and working WebSockets.

    Your error can be reproduced by using git clone command instead of using local repo. I mean NodeBB needs to be installed in a different way.

    Check your logs for errors.



  • @Mikael Hey mate 🙂
    I deleted the theme file and download it back using npm install. But it still shows the error Can I know which file is responsible for this part? .



  • Do you have socket.io 1.2.1 installed?



  • @nhl-pl Hi mate 🙂

    Yeah socket 1.2.1 installed
    I realized I receive the same problem whenever I tried to navigate to my website but in HTML form of it. Is it because of nginx?



  • Yes, it can be wrong nginx configuration fault.

    At the end of the article they show how to test it.

    If you have had it up and running without an issue it could be something else. In such scenario it could be a problem with plug-ins or themes.



  • @nhl-pl
    Thanks for the reply mate.
    I found out that the problem was nginx. So I googled and found the following command to remove nginx completely

    sudo apt-get remove nginx-core nginx-full nginx-light nginx-extras nginx-naxsi nginx-common

    After running this command, I installed it back using the sudo apt-get install nginx command and setup the config file as before. But the problem now is I get "page not found" but when I point to the server with the port number, it works. But if I type in without the pot number, it shows the "page not found". 😞



  • Again, you can solve it with config files. Paste your config.json and nginx vhost if you want any additional help.



  • @nhl-pl
    Hey mate 🙂
    This is my code in the file.

    server {
    listen 80;
    
        server_name http://server ip;
    location / {
    
        allow all;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header Host $http_host;
        proxy_set_header X-NginX-Proxy true;
    
        proxy_pass http://127.0.0.1:4567/;
        proxy_redirect off;
    
        # Socket.IO Support
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";
    }
    }
    

    And I do realise that I didn't have any default config file in the sites-available or the sites-enabled folder.



  • Please change server_name http://server ip; to server_name your-domain-here.com; and restart nginx.



  • @nhl-pl
    I restarted it and got this error
    awk: fatal: cannot open file `/etc/nginx/nginx.conf' for reading (No such file or directory)

    I think this is the reason its not working. Finally made it work. But the problem is:
    it shows the same problem as mentioned at the first post at the top "the invalid error name"



  • @gvimlan said:

    it shows the same problem as mentioned at the first post at the top "the invalid error name"

    Try to register a new user and log-in. If it works fine you should re-install NodeBB.


 

| |