NodeBB 0.7.0-dev fails to install



  • Hi,

    I've been trying to install the latest NodeBB dev version for quite some time today, and seem to fail at both an existing and fresh installation.

    Following both the steps for upgrading and installing here, I've practically tried every possible combination now:

    • Upgrading from 0.6.x to 0.7.0 via the instructions in the docs
    • A new installation via the instructions in the docs
    • A new installation on a completely new VPS with the instructions in the docs
    • A new installation, on Ubuntu (Instead of Debian), following this guide

    Sometimes I can't even npm install due to some HTTP error, though most of the time the following error occurs when I try to ./nodebb setup:

    module.js:356
    Module._extensions[extension](this, filename);
    ^
    Error: /home/webserver/web/blockify.us/public_html/forums/node_modules/mmmagic/build/Release/magic.node: undefined symbol: node_module_register
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/home/webserver/web/blockify.us/public_html/forums/node_modules/mmmagic/index.js:3:13)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)

    Any help is much appreciated. Thanks in advance.

    Node version: 0.12.1
    NPM version: 2.5.1



  • Fixed. Turned out to be a problem with my node/npm version.



  • If you can post the steps you took to resolve the problem it might help others who run into the same issue.



  • I'm also using:

    Node version: 0.12.1
    NPM version: 2.5.1

    Same problem. My forum is now down completely. Please advise on how you fixed OP.

    Anyone else can help, here's my errors.

    npm WARN package.json nodebb-plugin-soundpack-default@0.1.1 No README data
    npm WARN package.json reds@0.2.4 No repository field.
    npm WARN unmet dependency /root/forum/node_modules/prompt requires     winston@'0.8.x' but will load
    npm WARN unmet dependency /root/forum/node_modules/winston,
    npm WARN unmet dependency which is version 0.9.0
    npm ERR! Linux 3.13.0-37-generic
    npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "install"
    npm ERR! node v0.12.1
    npm ERR! npm  v2.5.1
    npm ERR! code EPEERINVALID
    
    npm ERR! peerinvalid The package nodebb-theme-vanilla does not satisfy its siblings' peerDependencies requirements!
    npm ERR! peerinvalid Peer nodebb-plugin-spam-be-gone@0.4.0 wants nodebb-theme-vanilla@>=0.0.137
    npm ERR! peerinvalid Peer nodebb-theme-lavender@1.0.27 wants nodebb-theme-vanilla@^1.0.0
    npm ERR! peerinvalid Peer nodebb-theme-flip@0.0.10 wants nodebb-theme-vanilla@~0.0.111
    npm ERR! peerinvalid Peer nodebb-theme-material@0.0.8 wants nodebb-theme-vanilla@^0.2.0
    npm ERR! peerinvalid Peer nodebb-theme-pewter@0.2.3 wants nodebb-theme-vanilla@~0.0.13
    
    npm ERR! Please include the following file with any support request:
    npm ERR!     /root/forum/npm-debug.log
    npm WARN package.json nodebb-plugin-soundpack-default@0.1.1 No README data
    npm WARN package.json reds@0.2.4 No repository field.
    npm WARN unmet dependency /root/forum/node_modules/prompt requires winston@'0.8.x' but will load
    npm WARN unmet dependency /root/forum/node_modules/winston,
    npm WARN unmet dependency which is version 0.9.0
    npm ERR! Linux 3.13.0-37-generic
    npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "i" "nodebb-theme-vanilla" "nodebb-theme-lavender" "nodebb-widget-essentials"
    npm ERR! node v0.12.1
    npm ERR! npm  v2.5.1
    npm ERR! code EPEERINVALID
    
    npm ERR! peerinvalid The package nodebb-theme-vanilla does not satisfy its siblings' peerDependencies requirements!
    npm ERR! peerinvalid Peer nodebb-plugin-spam-be-gone@0.4.0 wants nodebb-theme-vanilla@>=0.0.137
    npm ERR! peerinvalid Peer nodebb-theme-lavender@1.0.27 wants nodebb-theme-vanilla@^1.0.0
    npm ERR! peerinvalid Peer nodebb-theme-flip@0.0.10 wants nodebb-theme-vanilla@~0.0.111
    npm ERR! peerinvalid Peer nodebb-theme-material@0.0.8 wants nodebb-theme-vanilla@^0.2.0
    npm ERR! peerinvalid Peer nodebb-theme-pewter@0.2.3 wants nodebb-theme-vanilla@~0.0.13
    
    npm ERR! Please include the following file with any support request:
    npm ERR!     /root/forum/npm-debug.log


  • More errors, from ./nodebb dev

    (Had to screenshot, forum is flagging pasted one up as spam on Akismet)

    ss2.png ss1.png



  • @Affixes - any help on how you achieved it? I'm sitting with a dead website here.

    It seems mmmagic is the problem, I'm absolutely stuck. Short of reinstalling the forum, I'm out of ideas.



  • Why not use older versions of Node.js, NPM and stable release of NodeBB (26/03/2015)?



  • I have the same problem on running upgrade
    #npm version
    nodebb: '0.6.1',
    npm: '2.5.1',
    http_parser: '2.3',
    modules: '14',
    node: '0.12.1',
    openssl: '1.0.1m',
    uv: '1.0.2',
    v8: '3.28.73',
    zlib: '1.2.8'


Log in to reply
 

Suggested Topics

| |