[nodebb-plugin-rss] RSS Feed plugin



  • So sad.. half of the RSS feeds i got on my forum doesn't display the link of the content 😞



  • my feed that doesnt show links are:

    http://feeds.feedburner.com/smartbear (feedburner)

    blog.eviltester.com /feeds/posts/default (atom) (doesnt work)

    watirmelon.com /feed/ (wordpress feed)

    http://rafaelchiavegatto.com.br/rss/ (ghost blog)

    (added some white space za the link wasnt showing...)



  • @baris your rss feed did not post the url, it's before iframely could generate. Please help to get the url posted again, please please please 🙏

    What your RSS plugin posted:
    0_1463466042347_Screen Shot 2016-05-17 at 2.18.44 PM.png

    Sample of of the RSS:
    https://github.com/gozman/slack-rss RSS for Node Tue, 17 May 2016 06:14:14 GMT 30 http://www.newyorker(dot)com/tech/elements/the-coming-horror-of-virtual-reality?intcid=mod-latest http://www.newyorker(dot)com/tech/elements/the-coming-horror-of-virtual-reality?intcid=mod-latest

    Note: Replaced I've replaced . with (dot) to prevent a preview generated about the url.



  • Same issues as others are having now, RSS feeds work, but no links are posted or generated before the topic itself is.


  • Staff Admin

    Not sure what you guys are after, the plugin gets the content from the rss and posts thats as the content of the topic. So whatever content is in the feed entry gets posted. Do you want the rss url you put into the ACP page to also appear in the content?


  • Staff Admin

    0.3.11 should include the entry url in the content.



  • hey, i've installed the plugin on my nodebb v1.0.3 and reloaded and restarted the forum, but it's not showing up in my Plugins list. help?

    Edit: OK, i downgraded to 0.3.8 and now it shows. bug, maybe?

    Edit Edit: Any way to "force" refresh the feed to test it?


  • Plugin & Theme Dev

    @_axe v0.3.11 has a typo that's why it's not registering on activation. Sent a PR. You can wait for new version or upgrade to v0.3.11, make the change manually and reload.

    https://github.com/barisusakli/nodebb-plugin-rss/pull/27


  • Staff Admin

    0.3.12 has been published with the fix. Thanks @pichalite



  • @baris Thank you so much, the text and URL are showing up perfectly. 😊 Have an awesome week!



  • Hi!
    First things first, thank you for this awesome plugin! It's a really cool feature that I could add to my forum.

    I'm running it on NodeBB 1.1.2, but sometimes the logs are displaying this:

    error: [[nodebb-plugin-rss:error]] Error pulling feed http://xxxxxx.xx/feed connect ECONNREFUSED 98.137.200.255:443

    This IP looks like it's from yahoo, and I've read that you're using yahoo api, did they changed something?
    Do you know how can I fix this?

    Thank you!



  • Hi, this is a really nice plugin. I have a question or a little nag, though. Actually it's really specific so if there was a way I could just fix it for myself I'd be happy. (I'm way too novice to try to fork your code though.)

    When you use the RSS plugin to pull in posts to your NodeBB from Steam community pages there is a peculiar problem with parsing images.

    For an example:

     [http://steamcommunity.com/sharedfiles/filedetails/?id=790302505](http://steamcommunity.com/sharedfiles/filedetails/?id=790302505)
    

    That is what it posts instead of an image or even a clickable link to the image. I don't know why it's spitting that out. Steam looks like it uses BBcode but that's not what that is. That looks more like making a hyperlink on Reddit.

    Is there anything I can do about this? I'd like it to just go ahead and parse the image. I would settle for a link. Thanks for the great plugin in any case though!


  • Staff Admin

    The plugin turns html into markdown so that's why it appears as [](), that is a markdown link. Like this http://steamcommunity.com/sharedfiles/filedetails/?id=790302505 It appears the file is 404.



  • @baris Aah! I installed nodebb-plugin-markdown and it made that ugly spew transform into links. Well, there is my wish granted. Thanks for pointing me in the right direction. It just wasn't clicking for me. And thanks again for the lovely plugin!



  • Seems like it stopped to work with 1.4.0 😞

     7/12 00:00 [24258] - info: [plugin-rss] posting, http://blog.eviltester.com/feeds/posts/default - title: [object Object], published date: 2016-12-01T21:20:00Z
     7/12 00:00 [24258] - error: TypeError: str.replace is not a function
    at Object.module.exports.utils.slugify (/home/forum/NodeBB/public/src/utils.js:89:14)
    at async.waterfall.topicData (/home/forum/NodeBB/src/topics/create.js:38:33)
    at fn (/home/forum/NodeBB/node_modules/async/lib/async.js:746:34)
    at /home/forum/NodeBB/node_modules/async/lib/async.js:1213:16
    at /home/forum/NodeBB/node_modules/async/lib/async.js:166:37
    at /home/forum/NodeBB/node_modules/async/lib/async.js:706:43
    at /home/forum/NodeBB/node_modules/async/lib/async.js:167:37
    at /home/forum/NodeBB/node_modules/async/lib/async.js:1209:30
    at /home/forum/NodeBB/src/database/mongo/hash.js:244:4
    at handleCallback (/home/forum/NodeBB/node_modules/mongodb/lib/utils.js:96:12)
    at /home/forum/NodeBB/node_modules/mongodb/lib/collection.js:2482:14
    at handleCallback (/home/forum/NodeBB/node_modules/mongodb/lib/utils.js:96:12)
    at /home/forum/NodeBB/node_modules/mongodb/lib/db.js:309:5
    at /home/forum/NodeBB/node_modules/mongodb-core/lib/connection/pool.js:436:18
    at _combinedTickCallback (internal/process/next_tick.js:67:7)
    at process._tickCallback (internal/process/next_tick.js:98:9)
     TypeError: str.replace is not a function
    at Object.module.exports.utils.slugify (/home/forum/NodeBB/public/src/utils.js:89:14)
    at async.waterfall.topicData (/home/forum/NodeBB/src/topics/create.js:38:33)
    at fn (/home/forum/NodeBB/node_modules/async/lib/async.js:746:34)
    at /home/forum/NodeBB/node_modules/async/lib/async.js:1213:16
    at /home/forum/NodeBB/node_modules/async/lib/async.js:166:37
    at /home/forum/NodeBB/node_modules/async/lib/async.js:706:43
    at /home/forum/NodeBB/node_modules/async/lib/async.js:167:37
    at /home/forum/NodeBB/node_modules/async/lib/async.js:1209:30
    at /home/forum/NodeBB/src/database/mongo/hash.js:244:4
    at handleCallback (/home/forum/NodeBB/node_modules/mongodb/lib/utils.js:96:12)
    at /home/forum/NodeBB/node_modules/mongodb/lib/collection.js:2482:14
    at handleCallback (/home/forum/NodeBB/node_modules/mongodb/lib/utils.js:96:12)
    at /home/forum/NodeBB/node_modules/mongodb/lib/db.js:309:5
    at /home/forum/NodeBB/node_modules/mongodb-core/lib/connection/pool.js:436:18
    at _combinedTickCallback (internal/process/next_tick.js:67:7)
    at process._tickCallback (internal/process/next_tick.js:98:9)

  • Staff Admin

    Seems like the real issue is entry.title is an Object

    [plugin-rss] posting, http://blog.eviltester.com/feeds/posts/default - title: [object Object], published date: 2016-12-01T21:20:00Z
    

  • Staff Admin

    Published 1.1.4.

    • Added ability to test feeds before publishing
    • Fixed issue where some topic titles showed up as [Object object]
    • Added confirmation to feed removal.

  • Staff Admin

    Published 1.1.5

    • Added support for github flavored markdown, can be enabled in settings page.

  • Staff Admin

    Published 1.1.7.

    • Improved table rendering
    • Added cache buster to feed retrieval
    • Fixed issue with saving settings


  • @baris hi, have you seen that problem?

    Since I've updated to nodebb@1.6, and updated the RSS module, I can't add RSS feeds : 0_1506692901962_b5fb6407-e67a-48ad-9423-8ccaf70af60b-image.png


Log in to reply
 

Suggested Topics

| |