Forbidden at Login

General Discussion
  • Hello,

    I installed NodeBB on Uberspace (CentOS) and all worked just fine.

    But I can't login. When I try, a new tab opens with the single word "Forbidden".

    I have the newest versions of Node.js, NPM, NodeBB (0.6.x branch) and MongoDB. The user exists. Same thing with register.

    Are there log files?
    Any suggestions?

    Hope you can help me.


  • It doesn't sound like a normal problem.

    Try starting NodeBB with ./nodebb dev

    This will allow you to see any errors and logs as they happen.

    Look in the bruiser console for errors as well. Is everything (especially JavaScript) loading correctly?

  • This post is deleted!
  • Solved! Well, Uberspace ...

    Hope that will help other users to run NodeBB with Uberspace. The problem was the run-file I used for the daemon.

    This is my new code. ([USER]/etc/[YOUR-SERVICE]/run😞

    ./nodebb start

    In the official NodeBB documentation the preffered method to start is ./nodebb start.
    Don't follow third party tutorials in this case ... NodeBB seems unstable with other methods to start.

    I will test it further, but for now it seems to work pretty well.

Suggested Topics