Blank forum when not logged in

Bug Reports
  • I'm always scared to upgrade because I know there will have always a problem lol. This time I have no clue what is it about.

    When not logged in, there is only 1 category showing and widgets are blank. When logged in, everything appears, excepted "Recent posts" which is blank.


    And in ACP I've got the same thing than Tom

    Another bug but this time on mobile (I know i'm reporting too much bugs 😛 )

    Any idea on what's wrong please?

  • @Alex for categories issue, try the solution in gh#2750

    The mobile issue is scheduled for next version v0.7.0

  • At least I wasn't the only one. Thank you I will try it when I will come back from work.

  • @Alex before trying the solution from gh#2750 (which may not be related, actually), please review the permissions for each category. My bet is guests don't have Find/Access and Read ticked.

  • But @julian I can't review the permissions for the categories in the ACP as it's blank as well. I don't use cloudflare or any cloud cdn, redis is well configured and is used as websocket store, the url in the config.json is also good.

    Edit: It seems to be a websocket issue. In the browser console I can see that the connection failed. WebSocket connection to 'ws://' failed: Error during WebSocket handshake: Unexpected response code: 400

    my config.json

    "secret": "",
    "bind_address": "",
    "database": "redis",
    "redis": {
        "host": "",
        "port": "6379",
        "password": "",
        "database": "0"
    "url": ""


  • I tried @priapo's solution from and a lot of other things but It's still not working.

    It will be 3 days now and members in my community keeps harassing me lol. I would really appreciate if someone have got an idea. Thanks

  • @Alex It does sound like you've got some corrupt data in your database, though we'll have to figure out why...

    Would you mind sending us a copy of your database?

  • Yes sure. I've got a backup of the db and nodebb from 0.5.7. As you think it's a db issue. Does it worth it to try to upgrade it again from this version?

    Edit: I restored the backup (0.5.7) of nodebb and the db, upgraded again to 0.6.1, I tried several times. It's still the same. I also tried to upgrade from 0.5.7 to master, and still the same. Always getting those websockets error in the browser console

    Edit 2: Alright so this time I tried a fresh install of nodebb with a fresh db. I can see all the default categories created by nodebb this time but I still see the websockets error in the browser console and still have got the same issue in the admin certainly to do websockets failing.

    Now I know it's not an issue with the db or the upgrade (I think) but maybe with the proxy in apache even with this , it wasn't working. I precise that I've got apache 2.2.22 with wstunnel (more recent) backported.

    Edit 3: I directly accessed nodebb without going through apache proxy. I had no errors so I could have fixed the categories permissions. I still need to know why the proxy reverse can't handle websockets anymore after having upgraded nodebb.

Suggested Topics