Recent plugin upgrade beak everything

  • Plugin & Theme Dev

    @a_5mith said:

    The nbbpm plugin system that's being implemented was backported to 0.5.x stable. Which is still technically 0.5.4, the issue with backporting into an existing version, is although their has technically been an update, it's still 0.5.4, so the NodeBB system will tell you you're up to date.

    Seriously what's the logic behind this?


  • So is this why doing a simple nodebb upgrade fixed all my problems?


  • @Schamper I'd say it was more an oversight, everyone on 0.5.4 requires these changes in order to avoid installing the wrong plugin version, however at the same time, the oversight came in when existing 0.5.4 users, would have to "upgrade" to the same version in order to benefit from this. Not everyone runs git pull that often unless they're changing versions or if they're on master.

    Unfortunately it's one of those things that has to happen to improve on NodeBB, it just happened in the wrong order. Well, I say the wrong order, the nbbpm was implemented, then it was discovered that users on 0.5.x would receive incompatible plugins, so a fix was backported, that not everyone downloaded, so the issue arose anyway for some users. On the plus side, it shouldn't happen again. 😄 Well, not until plugin authors have to support the rel=nofollow...

  • Plugin & Theme Dev

    @a_5mith said:

    @Schamper I'd say it was more an oversight, everyone on 0.5.4 requires these changes in order to avoid installing the wrong plugin version, however at the same time, the oversight came in when existing 0.5.4 users, would have to "upgrade" to the same version in order to benefit from this. Not everyone runs git pull that often unless they're changing versions or if they're on master.

    I don't understand why this wasn't thought through. Recently npm removed the ability to republish existing version, isn't that a huge giveaway that, ya know, you should probably make it 0.5.5?

    Would really like a comment about this from the dev team.

  • GNU/Linux Admin

    The updates to the ACP Plugins panel to utilise the NodeBB Package Manager were backported to v0.5.x, and immediately published (to GitHub) as v0.5.4. v0.5.x branch should have this, and if it doesn't, that's a bit of a problem, I'd say.

    Also, we don't publish NodeBB to npm. Someone beat us to it, but they don't maintain it 😛

    @Schamper Thanks for keeping us accountable

  • Plugin & Theme Dev

    @julian said:

    The updates to the ACP Plugins panel to utilise the NodeBB Package Manager were backported to v0.5.x, and immediately published (to GitHub) as v0.5.4. v0.5.x branch should have this, and if it doesn't, that's a bit of a problem, I'd say.

    Also, we don't publish NodeBB to npm. Someone beat us to it, but they don't maintain it 😛

    @Schamper Thanks for keeping us accountable

    But was 0.5.4 already released prior to this? The problem here is that no one knows there's an "update" available because they already have 0.5.4.

    My point for npm was that it's probably a bad idea in general to release an update under the same version number.


  • I had a different problem with updating recently. I'm still one v0.5.4, but updated using npm. This updated the Vanilla theme, which my own theme (a Lavender clone with mods) depends on, actually updating after this commit, which broke everything. The csrf thingy was removed from the latest theme release but not from the latest release of NodeBB, breaking login and eventually other stuff that happen after login.

    I changed the required version of nodebb-theme-vanilla to 0.1.38 in NodeBB's package.json and installed the correct version, everything's fine.

    If anyone has the same problem and want a quickfix:

    npm remove nodebb-theme-vanilla
    npm install [email protected]
    

  • @Schamper even a 0.5.4.1 would do.

  • GNU/Linux Admin

    Prior to the backporting, the latest v0.5.x version was v0.5.3, so there should not have been any problems with installing packages on v0.5.4, except if you installed a package that was upgraded to v0.6.0 compatibility but did not properly follow the recommended procedures regarding publishing of a v0.5.x compatible version with compatibility hash.


  • @julian The plugins I installed were the ones the NodeBB look after?
    Google Analytics
    DBSearch
    Markdown
    Widget essentials

    This was on 0.5.4 and then after @a_5mith post i tried to update nodebb and there was an update but the ACP did not know that there was one. Once i updated from 0.5.4 to 0.5.4-newer the plugins worked.

  • GNU/Linux Admin

    Ah yes, true. I will admit that the Upgrade Button specifically was not changed for the initial release of v0.5.4.

    They were added after, but not republished as v0.5.5, yet.

    Waiting on gh#2438

    julianlam created this issue in NodeBB/NodeBB

    closed Package Manager Inclusion Criteria #2438


Suggested Topics

  • 5
  • 1
  • 1
  • 29
  • 7
| | |

© 2014 – 2022 NodeBB, Inc. — Made in Canada.