[Solved] Forum restarting when new post submitted



  • Hello there's a new bug on master branch, when a user posts it makes the forum restart because of this error

    error: TypeError: undefined is not a function
        at /home/esiao/gg_nodebb/src/posts.js:529:5
        at try_callback (/home/esiao/gg_nodebb/node_modules/redis/index.js:573:9)
        at RedisClient.return_reply (/home/esiao/gg_nodebb/node_modules/redis/index.js:661:13)
        at ReplyParser.<anonymous> (/home/esiao/gg_nodebb/node_modules/redis/index.js:309:14)
        at ReplyParser.EventEmitter.emit (events.js:95:17)
        at ReplyParser.send_reply (/home/esiao/gg_nodebb/node_modules/redis/lib/parser/javascript.js:300:10)
        at ReplyParser.execute (/home/esiao/gg_nodebb/node_modules/redis/lib/parser/javascript.js:189:22)
        at RedisClient.on_data (/home/esiao/gg_nodebb/node_modules/redis/index.js:534:27)
        at Socket.<anonymous> (/home/esiao/gg_nodebb/node_modules/redis/index.js:91:14)
        at Socket.EventEmitter.emit (events.js:95:17)
    [cluster] Child Process (32079) has exited (code: 1)
    [cluster] Spinning up another process...

  • Admin

    This might be caused by a plugin. I'm guessing it is the mentions plugin that you need to update.

    The signature of getPidIndex is now getPidIndex(pid, uid, next) so make sure the plugins you are using are using that.



  • @baris It's effectively mentions plugin causing the problem. But I can't update it npm don't want because my vanilla version is not the one it expect. Is there a way to force it ? or should I take the github version without considering npm (it's a dev environment so no problem).


  • Admin

    Hmm maybe its not published to npm @julian? Either way the latest from master should work fine.


  • Admin

    Mentions 0.6.2 should be the latest, and should contain the fix that @baris wrote... can you confirm that that's the version you have @esiao ?



  • @julian That's the version I have. And it seems to be fixed (maybe a cache issue)


 

| |