Error on Startup(socket.io and nodebb-plugin-finder)

Bug Reports
  • #1

    This happens when I try to start the latest git version

    Error: Cannot find module './socket.io/tools'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Module.require (module.js:364:17)
    at /home/punkbob/nodebb/node_modules/nodebb-plugin-finder/library.js:13:32
    at Object.<anonymous> (/home/punkbob/nodebb/node_modules/nodebb-plugin-finder/library.js:231:2)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)

  • #2

    @Punkbob Did you run ./nodebb upgrade after pulling the latest changes from git?

  • #3

    Yes, I did, still comes up with the same error.

    It also complains about a ton of other plugins.

  • NodeBB
    #4

    You don't really need nodebb-plugin-finder anymore since we kind of built that functionality into the ACP itself.

  • #5

    @baris I killed the plugin, and restarted nodebb when I was troubleshooting, and the entire server crashed.

    However just tried it again, and all is well. No idea what happened.

  • Community Rep
    #6

    If the socket.io/tools.js module was deleted, then this won't work since the plugin was depending on that. I saw that there's a plugins.js module in the same place now, so i can amend it to user that instead. However I've just pulled the latest and can't get it to connect to redis, starting a separate thread...


Suggested Topics


| | | |