[loader] Experienced three start attempts in 10 seconds, most likely an error on startup. Halting.


  • I wanna test NodeBB on my server, but I cant running up. any idea?

    info: NodeBB v0.4.3 Copyright (C) 2013-2014 NodeBB Inc.
    info: This program comes with ABSOLUTELY NO WARRANTY.
    info: This is free software, and you are welcome to redistribute it under certain conditions.
    info:
    info: Time: Sat Jul 26 2014 10:27:44 GMT+0800 (CST)
    info: Initializing NodeBB v0.4.3
    info: * using configuration stored in: /xxxx/xxxx/xxxxx/config.json
    info: * using redis store at 127.0.0.1:6379
    info: * using themes stored in: /xxxx/xxxx/xxxxx/node_modules
    info: Base Configuration OK.
    warn: You have no redis password setup!
    morgan deprecated morgan(options): use morgan("default", options) instead src/logger.js:128:22
    morgan deprecated default format: use combined format src/logger.js:128:22
    info: [notifications.init] Registering jobs.
    info: [user.startJobs] Registering User Jobs
    info: Enabling 'trust proxy'
    info: [plugins] Initializing plugins system
    info: [plugins] Sorting hooks to fire in priority sequence
    info: [plugins] Plugins OK
    info: [meta/css] Minifying LESS/CSS
    info: [sounds] Sounds OK
    info: [themes] Using theme nodebb-theme-vanilla
    info: Middlewares loaded.
    info: [themes] Compiling templates
    info: [meta/css] Done.
    info: [themes] Successfully compiled templates.
    info: NodeBB attempting to listen on: www.xxxxxxx.com:80
    error: NodeBB address in use, exiting...

    [loader] Experienced three start attempts in 10 seconds, most likely an error on startup. Halting.

  • Plugin & Theme Dev

    @Gateman It appears that something is already using port 80. Do you have something like cPanel or Plesk installed on this server? If so, something could already be using that port or it could be something else.

    Have you tried setting it to the default :4567 and using nginx or apache to reverse proxy to port 80?


  • @Tanner yes, I have Nginx on my server, Let me try setting it to 4567.

  • GNU/Linux Admin

    Hey @Gateman, this document might help you out. It'd be best to set the port that NodeBB listens on to 4567, and have nginx proxy requests for port 80 to localhost:4567, which is your NodeBB server.


  • @julian @tanner thanks a lot guys, problem has been solved.

    really helpfull!

Suggested Topics

| |