• Hi
    I don't success to install the NodeBB
    the error:

    Dependencies outdated or not yet installed.
    Installing them now...
    
    npm notice Beginning October 4, 2021, all connections to the npm registry - including for package installation - must use TLS 1.2 or higher. You are currently using plaintext http to connect. Please visit the GitHub blog for more information: https://github.blog/2021-08-23-npm-registry-deprecating-tls-1-0-tls-1-1/
    npm notice Beginning October 4, 2021, all connections to the npm registry - including for package installation - must use TLS 1.2 or higher. You are currently using plaintext http to connect. Please visit the GitHub blog for more information: https://github.blog/2021-08-23-npm-registry-deprecating-tls-1-0-tls-1-1/
    npm WARN deprecated [email protected]: request-promise-native has been deprecated because it extends the now deprecated request package, see https://github.com/request/request/issues/3142
    npm WARN deprecated [email protected]: this library is no longer supported
    npm WARN deprecated [email protected]: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
    npm WARN deprecated [email protected]: request has been deprecated, see https://github.com/request/request/issues/3142
    npm WARN deprecated [email protected]: support for ECMAScript is superseded by `uglify-js` as of v3.13.0
    npm WARN deprecated [email protected]: You can find the new Popper v2 at @popperjs/core, this package is dedicated to the legacy v1
    npm ERR! code 1
    npm ERR! path C:\Users\User\Desktop\NodeBB\node_modules\sharp
    npm ERR! command failed
    npm ERR! command C:\WINDOWS\system32\cmd.exe /d /s /c (node install/libvips && node install/dll-copy && prebuild-install) || (node install/can-compile && node-gyp rebuild && node install/dll-copy)
    npm ERR! sharp: Downloading https://github.com/lovell/sharp-libvips/releases/download/v8.12.2/libvips-8.12.2-win32-x64.tar.br
    npm ERR! sharp: Please see https://sharp.pixelplumbing.com/install for required dependencies
    npm ERR! sharp: Installation error: unable to get local issuer certificate
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     C:\Users\User\AppData\Local\npm-cache\_logs\2022-04-19T17_36_51_616Z-debug-0.log
    Error installing dependencies!
    message: Command failed: npm install --production
    stdout: null
    stderr: null
    C:\Users\User\Desktop\NodeBB\src\cli\package-install.js:142
                    throw e;
                    ^
    
    Error: Command failed: npm install --production
        at checkExecSyncError (node:child_process:828:11)
        at Object.execSync (node:child_process:902:15)
        at Object.pkgInstall.installAll (C:\Users\User\Desktop\NodeBB\src\cli\package-install.js:133:9)
        at Object.<anonymous> (C:\Users\User\Desktop\NodeBB\src\cli\index.js:51:18)
        at Module._compile (node:internal/modules/cjs/loader:1097:14)
        at Object.Module._extensions..js (node:internal/modules/cjs/loader:1149:10)
        at Module.load (node:internal/modules/cjs/loader:975:32)
        at Function.Module._load (node:internal/modules/cjs/loader:822:12)
        at Module.require (node:internal/modules/cjs/loader:999:19)
        at require (node:internal/modules/cjs/helpers:102:18) {
      status: 1,
      signal: null,
      output: [ null, null, null ],
      pid: 14724,
      stdout: null,
      stderr: null
    }
    
    Node.js v17.4.0
    

    How to fix it?
    Thank you

  • Global Moderator Plugin & Theme Dev

    Guessing you're on a corporate proxy or something?

    https://github.com/lovell/sharp/issues/1618


  • @PitaJ Thank you!


Suggested Topics

| | |

© 2014 – 2022 NodeBB, Inc. — Made in Canada.