can nodebb be installed on Apache 2 server?

Solved Technical Support

Suggested Topics

  • 0 Votes
    5 Posts

    Well I had to change nodeBB theme, and rebuild it ... Finally it works.
    Before I revoked sessions in admin panel, users were clearing cookies but nothing helped.

  • Error Starting NodeBB

    Technical Support
    1 Votes
    20 Posts

    Pardon me, my mistake. The icon set wasnt active in the dasshboard

  • Offline Installation

    Technical Support
    0 Votes
    2 Posts
  • Add PHP API

    NodeBB Development
    0 Votes
    32 Posts
    <?php class nodebb { function category_add ($params='name=Default category name', $token='e9de6fb6-1234-5678-8bbc-b5073fd1edef'){ shell_exec('/usr/bin/curl -H "Authorization: Bearer '.$token.'" --data "'.$params.'" http://localhost:4567/forum/api/v1/categories'); } } $nodebb = new nodebb; $nodebb->category_add(); return false;

    Now it's much easier 🙂

  • 0 Votes
    1 Posts

    I'm trying to create a user via php to be recognized by nodebb authentication form. I do this via predis, so I can talk to redis via php.
    This is the relevant part of the code that creates a user in redisdb for nodebb in php:

    But sadly, when I tried to login with such created account via php it didn't work and said "User does not exists".
    I checked all 'legit' userdata with my userdata created by php and I can't detect any flaws

    This is what I told php to create in redis, it's all verified and there:

    populate 'user:#' with 22 key's where # is uid populate 'email:uid' with user email and uid populate 'group:registered-users:members' with uid populate 'users:joindate' with 0 and uid populate 'users:joindate' with 0 and uid populate 'users:postcount' with 0 and uid populate 'reputation' with 0 and uid populate 'username:uid' with username and uid populate 'userslug:uid' with userslug and uid

    What am I missing :C??? I checked redis and the data is all their, but nodebb says the user does not exists

    EDIT: I checked the users tab in admin and saw that the username is there that was created from php. After I press the save button on the profile edit page of that profile, that account can then login! how strange. I'm going to do more digging until someone knows what i'm missing here.

    EDIT 2: I forgot slugifying userslug:uid in redis. Finally fix it 🙂