Since 1.17: cropper.js failed (13: Permission denied)


  • Since the upgrade to 1.17 I have many messages like this in the logfile:

    2021/04/26 00:14:35 [crit] 40408#40408: *679 open() "/var/www/mysite/nodebb/public/src/modules/cropper.js" failed (13: Permission denied), client: 178.xxx.xx.xxx,
    server: mysite.com, request: "GET /assets/src/modules/cropper.js?v=e0dn33rd4h0 HTTP/2.0", host: "mysite.com", referrer: "https://mysite.com/user/admin/edit"
    

    There is no /var/www/mysite/nodebb/public/src/modules/cropper.js. I found it at

    /var/www/mysite.com/nodebb/build/public/src/modules/cropper.js
    /var/www/mysite.com/nodebb/node_modules/cropperjs/dist/cropper.js
    /var/www/mysite.com/nodebb/node_modules/cropperjs/src/js/cropper.js
    

    What can I do? Just create a symlink maybe? Or is that too simple thinking.

  • Global Moderator Plugin & Theme Dev

    In what logfile? Nginx?


  • Yes, sorry. This is the nginx logfile.

  • Global Moderator Plugin & Theme Dev

    What is your nginx config?

Suggested Topics

| |