Check if all used components (themes, plugins,...) are up2date



  • Outdated themes caused major problems (cannot edit settings, change categories,...) with a fresh(!) installation of NodeBB for me. I had to wait for days to finally get the solution. This is really bad and might scare away admins who think about using NodeBB and don't even know that their themes are outdated (because they just installed the latest version as described in the docs)
    I would suggest to add a row "Components up2date" to the box which checks the version in the ACP. If something is not up2date, it should be displayed in a indented row below the "Components up2date" row. Colors might be green (ok), orange(unchecked) and red(outdated).

    See example GUI:

    up2date

    outdated



  • @Marco I think this may be something that will be a part of the plugin manager that @psychobunny is developing?
    If not it might be worth adding it in.


  • Admin

    I believe you and @Giorgio-Chiodi were experiencing this problem, but this only happens in the latest master branch, since the theme is updated regularly.

    v0.4.3 has hardcoded dependencies, and should have worked fine this entire time -- for production purposes, admins should be using that branch.



  • @julian I don't know julian, I followed the official installation guide. I believe such an addition would be necessary considering what happened.


  • Admin

    Re: #1551



  • @julian I followed the docs. I got an outdated version labeled 0.4.3. No one ever told me to update the themes. It really does not matter if everything worked fine for a long time. This should just show you that you need more testing. You obviously did not test installing version 0.4.3 as described in the docs directly.
    I know it's not easy to find bugs, but please seriously consider this request as it will prevent a lot of headaches in the future and show admins what might not be working. I cannot make a good bug report if I am using outdated software. I did not even know that it was outdated. You won't be able to solve future bugs if people use outdated software without knowing.

    BTW.: as I already wrote on github, renaming the branches won't help anyone if it contains outdated software or the docs are insufficient. I would be really glad to see my request beingf implemented and help thousands of people setting up a very nice forum.


  • Admin

    @Scuzz said:

    @Marco I think this may be something that will be a part of the plugin manager that @psychobunny is developing?
    If not it might be worth adding it in.

    yup that's right, so hopefully once that's done (for 0.5x) this problem will be a thing of the past :)



  • @Marco said:

    @julian I followed the docs. I got an outdated version labeled 0.4.3. No one ever told me to update the themes. It really does not matter if everything worked fine for a long time. This should just show you that you need more testing. You obviously did not test installing version 0.4.3 as described in the docs directly.
    I know it's not easy to find bugs, but please seriously consider this request as it will prevent a lot of headaches in the future and show admins what might not be working. I cannot make a good bug report if I am using outdated software. I did not even know that it was outdated. You won't be able to solve future bugs if people use outdated software without knowing.

    BTW.: as I already wrote on github, renaming the branches won't help anyone if it contains outdated software or the docs are insufficient. I would be really glad to see my request beingf implemented and help thousands of people setting up a very nice forum.


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.