NodeBB displaying blank screens when accessing subforums

  • Hi ya'll! Just recently installed a new copy of nodebb. I can navigate to my forum okay (, but when I click any of the subcategories, it loads a blank screen. (ex:, but if I edit the url to, it loads fine. If I try to click the title to go back to the root, it stays blank. Any ideas?

  • NodeBB

    See this post for the fix

  • Hi @baris.

    Thanks for the tip! I used npm i [email protected] to downgrade my version of jQuery, then upgraded and restarted the nodeBB process and I'm still having the same issue. Any other ideas of what it may be?

  • NodeBB

    If you upgrade nodebb after intalling [email protected], it probably upgraded jquery back to 3.5.0. Check what jquery is installed by npm ls jquery

  • @timoxazero Can't edit so replying to myself. Tried npm ls jquery. It was indeed 3.5.0 so I downgraded it back down and restarted the server, but the issue persists. It seems to be an issue with the navigation buttons themselves. When I access the category directly from the link I posted, I can see the subforum just fine. But if I navigate to the homepage and try to click "Applications", I encounter the issue.

    Edit: Ah. I can edit. Neat. Yeah so when I access directly, I can see the subforum, but I cannot interact with the button to write a post. If I navigate to htttps:// Then it opens a post writing window, but I can't submit it.

  • NodeBB

    After you downgrade jquery, run ./nodebb build so the client side payload is updated. But don't run ./nodebb upgrade. After that restart and it should work.

  • There we go. That worked. Thank you very much!

    Edit: Just kidding. I still can't click compose.

  • Found an error in the log that may have something to do with my issue composing new topics.

    (node:6721) UnhandledPromiseRejectionWarning: Error: Failed to lookup view "compose" in views directory "/home/timoxa/nodebb/build/public/templates"
        at Function.render (/home/timoxa/nodebb/node_modules/express/lib/application.js:580:17)
        at ServerResponse.render (/home/timoxa/nodebb/node_modules/express/lib/response.js:1012:7)
        at /home/timoxa/nodebb/src/middleware/render.js:63:83
        at internal/util.js:297:30
        at new Promise (<anonymous>)
        at internal/util.js:296:12
        at ServerResponse.renderOverride [as render] (/home/timoxa/nodebb/src/middleware/render.js:67:14)
        at processTicksAndRejections (internal/process/task_queues.js:97:5)

    Edit: Checked /home/timoxa/nodebb/build/public/templates and there's no files for composing. Is there a way to pull them from remote and just add them in?

    Edit 2: I found a compose.js in the github directory, and I added it to /home/timoxa/nodebb/build/public/templates as compose.js, and then i do ./nodebb build and it deletes the file every time. Any ideas? If I don't build it, but restart, it doesn't change anything.

  • NodeBB

    Running ./nodebb build will generate the template files in the build/public/templates folder. Make sure nodebb-plugin-composer-default is installed and activated.

  • That solved my problem. Thank you so much!!!!

Suggested Topics

| |