• I tried to upgrade 1.13.2 to the master, it says:

    [email protected]:/nodebb# ./nodebb upgrade
    1. Bringing base dependencies up to date... 
    Error: Command failed: /usr/bin/env npm i --production
    npm WARN deprecated [email protected]: Please upgrade to 2.2.19 or higher
    npm WARN deprecated [email protected]: use nodebb-plugin-emoji instead.
    npm WARN deprecated [email protected]: All versions below 4.0.1 of Nodemailer are deprecated. See https://nodemailer.com/status/
    npm WARN deprecated [email protected]: Jade has been renamed to pug, please install the latest version of pug instead of jade
    npm WARN deprecated [email protected]: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
    npm WARN deprecated [email protected]: CoffeeScript on NPM has moved to "coffeescript" (no hyphen)
    npm WARN deprecated [email protected]: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
    npm WARN deprecated [email protected]: request has been deprecated, see https://github.com/request/request/issues/3142
    npm WARN deprecated [email protected]: This project is unmaintained
    npm WARN deprecated [email protected]: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
    npm WARN deprecated [email protected]: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
    npm WARN deprecated [email protected]: This module moved to @hapi/hawk. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.
    npm WARN deprecated [email protected]: This project is unmaintained
    npm WARN deprecated [email protected]: XSS vulnerability fixed in v1.0.3
    npm WARN deprecated [email protected]: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
    npm WARN deprecated [email protected]: Please use the native JSON object instead of JSON 3
    npm WARN deprecated [email protected]: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
    npm WARN deprecated [email protected]: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
    npm WARN deprecated [email protected]: Please use the native JSON object instead of JSON 3
    npm WARN deprecated [email protected]: This module moved to @hapi/sntp. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.
    npm WARN deprecated [email protected]: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
    npm ERR! code 128
    npm ERR! Command failed: git clone --depth=1 -q -b v1.0.0 git://github.com/wzrdtales/simple-recaptcha.git /root/.npm/_cacache/tmp/git-clone-ec40cd00
    npm ERR! fatal: could not create leading directories of '/root/.npm/_cacache/tmp/git-clone-ec40cd00': Permission denied
    npm ERR! 
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /root/.npm/_logs/2020-03-05T22_11_04_988Z-debug.log
    
    

  • Now I simply revert to v1.13.2 by:

    git checkout v1.13.2
    ./nodebb build
    ./nodebb start
    

    But I want to upgrade...😧

  • Global Moderator Plugin & Theme Dev

    That error is caused by a permissions error, likely because you're running as root.

    nodebb should not be installed or run as a privileged user.


  • Um.. But I succeed many times before. I remember I upgraded it from 1.7 version or something like that ... Is it possible to handle that problem simply? It looks not convenient for me to re-install nodebb in my server. Thank you @PitaJ

  • Global Moderator Plugin & Theme Dev

    It is dangerous to run nodebb this way. Do so at your own risk.

    I'm not sure exactly what is causing that npm error, but it's not a NodeBB bug. I suggest you look it up yourself.


Suggested Topics

| | |

© 2014 – 2022 NodeBB, Inc. — Made in Canada.