Can't upload logo

Technical Support
  • @julian favicon is uploading just fine, why the issue are only with uploading logo and touchicon ?
    I didn't think its the issue with nodejs as its using official repo installation (centos 7)

  • Please try using Ubuntu 18.04

  • I met just same probelm too when I try to install nodebb last day. I can upload favicon but can't upload any other images. I used the same centos7 and v12.15.0 node.js. I looked up the installation log, it shows some modules did not installed well. For me it were sharp and some other modules. I guess it's the sharp module which is used to crop the images uploaded caused this problem. Sharp module need 'CXXABI_1.3.8' to compile and my default yum source did not have the gcc version needed. Maybe you can upgrade your gcc version and try reinstalling it by using "npm install sharp"? Hope this can help.

  • That is a good clue @BAKA, this is likely the issue. Perhaps sharp needs to be compiled manually by npm.

  • @BAKA said in Can't upload logo:

    I met just same probelm too when I try to install nodebb last day. I can upload favicon but can't upload any other images. I used the same centos7 and v12.15.0 node.js. I looked up the installation log, it shows some modules did not installed well. For me it were sharp and some other modules. I guess it's the sharp module which is used to crop the images uploaded caused this problem. Sharp module need 'CXXABI_1.3.8' to compile and my default yum source did not have the gcc version needed. Maybe you can upgrade your gcc version and try reinstalling it by using "npm install sharp"? Hope this can help.

    thanks @BAKA for the info, i'll install ubuntu 18.04 and get back here.

  • @julian thanks on ubuntu 18.04 there is no such issue. Centos 7 have issues which @BAKA mentioned with GCC version.

  • hopefully centos 8 doesn't have this issues πŸ™‚ thanks @BAKA

  • I've updated the gcc version but there is still the issue with RHEL/centos 7 @julian you should check nodebb compatibility with EL7. Else remove EL7 from the supported list.

  • @Sandeep where do we say we support CentOS? Just wondering, because we shouldn't, we try to be platform agnostic but target Ubuntu mainly.

  • okay thanks, probably stop using nodebb then πŸ™‚

    remove the docs from here

  • @Sandeep yes, the CentOS guide here is community supported, it should still work regardless (though you'll likely need to install the build tools so sharp can compile).

  • sharp compiles fine no issue @julian

    its on centos 7 :

    [[email protected] nodebb]# npm install sharp
    
    > [email protected] install /home/removed/web/removed.com/nodebb/node_modules/husky
    > node husky install
    
    husky > Setting up git hooks
    husky > Done
    
    > [email protected] install /home/removed/web/removed.com/nodebb/node_modules/sharp
    > (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)
    
    info sharp Detected globally-installed libvips v8.9.1
    info sharp Building from source via node-gyp
    make: Entering directory `/home/removed/web/removed.com/nodebb/node_modules/sharp/build'
      TOUCH Release/obj.target/libvips-cpp.stamp
      CXX(target) Release/obj.target/sharp/src/common.o
      CXX(target) Release/obj.target/sharp/src/metadata.o
      CXX(target) Release/obj.target/sharp/src/stats.o
      CXX(target) Release/obj.target/sharp/src/operations.o
      CXX(target) Release/obj.target/sharp/src/pipeline.o
      CXX(target) Release/obj.target/sharp/src/sharp.o
      CXX(target) Release/obj.target/sharp/src/utilities.o
      SOLINK_MODULE(target) Release/obj.target/sharp.node
      COPY Release/sharp.node
    make: Leaving directory `/home/removed/web/removed.com/nodebb/node_modules/sharp/build'
    
    > [email protected] postinstall /home/removed/web/removed.com/nodebb/node_modules/husky
    > opencollective-postinstall || exit 0
    
    Thank you for using husky!
    If you rely on this package, please consider supporting our open collective:
    > https://opencollective.com/husky/donate
    
    npm WARN [email protected] requires a peer of nodebb-plugin-emoji@^2.0.0 but none is installed. You must install peer dependencies yourself.
    npm WARN [email protected] requires a peer of textcomplete@^0.14.2 but none is installed. You must install peer dependencies yourself.
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    
    + [email protected]
    added 618 packages from 785 contributors, updated 1 package and audited 15834 packages in 44.557s
    
    33 packages are looking for funding
      run `npm fund` for details
    
    found 1 high severity vulnerability
      run `npm audit fix` to fix them, or `npm audit` for details
    
  • @julian please let me know if you still think its sharp issue, since it is installed fine.


Suggested Topics