Mail via Nodebb stops working (Postfix)



  • Hi gurus,
    We are using Postfix as a web server and was working fine with Nodebb.
    Recently we have noticed that it's not working anymore....

    The test from the server is OK using nodebb user

    echo "Test mail" | sendmail -i -f mail@domain.com mail@domain.com
    echo "Test mail | mail -s "subject" mail@domain.com
    
    
    nodebb:~$ id
    uid=1002(nodebb) gid=1002(nodebb) groups=1002(nodebb)
    
    

    Any idea ? What command is using by Nodebb to initiate the mails?

    Thank you 🙂


  • GNU/Linux Admin

    Hello @azeus -- we use the nodemailer library to send emails via a variety of service providers. The default fallback is to use the system mailer, which would be postfix if that is installed on your machine.

    Do you see any log messages on the server when mail is not sent? What happens if you send a test email via the Settings -> Emails page?



  • @julian said in Mail via Nodebb stops working (Postfix):

    hen mail is not sent? What happens if you send a test email via the Settings -> E

    Thanks for your support!

    The test email via the Setting > Emails says "SUCCESS Test Email Sent" but nothing in Postfix logs... Not sure what's really happens but it seems that the command dosn't arrive to the postfix server 😕


  • GNU/Linux Admin

    ... and the NodeBB Logs? (you can check them by running ./nodebb log)



  • The test mail generate this in nodebb logs:

    2020-01-21T15:17:23.841Z [8080/20347] - error: connect ECONNREFUSED 127.0.0.1:587 {"errno":"ECONNREFUSED","code":"ESOCKET","syscall":"connect","address":"127.0.0.1","port":587,"command":"CONN"}
    

  • GNU/Linux Admin

    @azeus Are you absolutely 100% sure postfix is running on port 587? 😉



  • @julian said in Mail via Nodebb stops working (Postfix):

    587

    Actually somehow Actually, somehow the submission parameter on port 587 wasn’t present anymore in my postfix settings… And the TLS certificate wasn’t valid anymore… Anyway, I’ve forced to use port 25 without certificate. Its working again 🙂

    Thank you again @julian


Log in to reply
 

Suggested Topics

| |