Error after upgrading to v1.13.1



  • Hello, i got this error

    1. Updating package.json file with defaults...  OK
    
    2. Bringing base dependencies up to date...  started
    
    > sharp@0.23.4 install /home/user/forum/nodebb/node_modules/sharp
    > (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)
    
    info sharp Using cached /home/user/.npm/_libvips/libvips-8.8.1-linux-x64.tar.gz
    internal/modules/cjs/loader.js:638
        throw err;
        ^
    

    What can i do to fix this?


  • GNU/Linux Admin

    Hm, odd... how much memory do you have in your server? Could be it's running out of memory.

    Perhaps try moving node_modules/ to a different folder, then running npm i --production again.



  • After

    apt install make
    apt install g++
    

    it works.

    Looks like sharp need to build some files!?!?!??

     make: Entering directory '/home/user_radforum/radforum/nodebb/node_modules/sharp/build'
       TOUCH Release/obj.target/libvips-cpp.stamp
       CXX(target) Release/obj.target/sharp/src/common.o
       CXX(target) Release/obj.target/sharp/src/metadata.o
       CXX(target) Release/obj.target/sharp/src/stats.o
       CXX(target) Release/obj.target/sharp/src/operations.o
       CXX(target) Release/obj.target/sharp/src/pipeline.o
       CXX(target) Release/obj.target/sharp/src/sharp.o
       CXX(target) Release/obj.target/sharp/src/utilities.o
       SOLINK_MODULE(target) Release/obj.target/sharp.node
       COPY Release/sharp.node
     make: Leaving directory '/home/user_radforum/radforum/nodebb/node_modules/sharp/build'
    

    Why?? First time i need this, i think...


  • GNU/Linux Admin

    It depends on your platform... sharp usually downloads its dependencies, but on unsupported platforms it will need to build its own local copy.

    Perhaps the new version hasn't been updated with downloadable binaries yet 😄



  • I am on Debian Buster 10


Log in to reply
 

Suggested Topics

| |