• GNU/Linux Admin

    @Guiri First stop is /var/log/redis 🙂


  • @julian Yes. Turns out I had to echo 1 > /proc/sys/vm/overcommit_memory. The forum has been running great!


  • Hey @julian, I've just installed NodeBB again on a clean Droplet, following psychobunnys noob guide for reference, and when logging in I got the same error. The page stops at /?loggedin with 500 Internal Server Error, api/config/ also has the same error, removing `/?loggedin' takes me back to the homepage, and I am logged in though.

    I went into NodeBBs logs and saw this node_redis: no callback to send error: ERR unknown command 'pexpire'

    Went into /var/log/redis, the only error in there was about overcommit_memory needing to be set to 1.

    Have I set up a duff droplet on Digital Ocean or something? I've installed NodeBB about 3 or 4 times now, but never had this issue.

  • NodeBB

    What version is your redis? You can see in the ACP>database. Looks like pexpire is only supported on redis 2.6.0 and up.


  • @baris Seems that could be the issue then, as it states my Redis version is 2.2.12.

    Have updated to version 2.8.9. Must have missed a command somewhere. 😕


  • Seems it hasn't been fixed. 😕

    I get this running ./nodebb dev

    error: TypeError: Cannot read property 'maxCount' of undefined
    at expandObjBy (/home/a_5mith/35hz/src/settings.js:7:14)
    at /home/a_5mith/35hz/src/settings.js:83:7
    at /home/a_5mith/35hz/src/meta.js:457:5
    at try_callback (/home/a_5mith/35hz/node_modules/redis/index.js:573:9)
    at RedisClient.return_reply (/home/a_5mith/35hz/node_modules/redis/index.js:661:13)
    at ReplyParser.<anonymous> (/home/a_5mith/35hz/node_modules/redis/index.js:309:14)
    at ReplyParser.EventEmitter.emit (events.js:95:17)
    at ReplyParser.send_reply (/home/a_5mith/35hz/node_modules/redis/lib/parser/javascript.js:300:10)
    at ReplyParser.execute (/home/a_5mith/35hz/node_modules/redis/lib/parser/javascript.js:211:22)
    at RedisClient.on_data (/home/a_5mith/35hz/node_modules/redis/index.js:534:27)
    
    
    TypeError: Cannot read property '_csrf' of undefined
    at Object.handle (/home/a_5mith/35hz/node_modules/express/node_modules/connect/lib/middleware/csrf.js:45:28)
     at next (/home/a_5mith/35hz/node_modules/express/node_modules/connect/lib/proto.js:190:15)
     at Object.session [as handle] (/home/a_5mith/35hz/node_modules/express/node_modules/connect/lib/middleware/session.js:218:61)
     at next (/home/a_5mith/35hz/node_modules/express/node_modules/connect/lib/proto.js:190:15)
     at Object.cookieParser [as handle] (/home/a_5mith/35hz/node_modules/express/node_modules/connect/lib/middleware/cookieParser.js:60:5)
    at next (/home/a_5mith/35hz/node_modules/express/node_modules/connect/lib/proto.js:190:15)
    at multipart (/home/a_5mith/35hz/node_modules/express/node_modules/connect/lib/middleware/multipart.js:64:37)
    at /home/a_5mith/35hz/node_modules/express/node_modules/connect/lib/middleware/bodyParser.js:57:9
    at urlencoded (/home/a_5mith/35hz/node_modules/express/node_modules/connect/lib/middleware/urlencoded.js:51:37)
    at /home/a_5mith/35hz/node_modules/express/node_modules/connect/lib/middleware/bodyParser.js:55:7
    

    Oh and redis version is 2.8.4, not 2.8.9. 🙂 Ubuntu version is 14.04 if this helps.

    Oh and everything worked fine until I tried enabling some plugins, installed and enabled, clicked Home to restart nodebb, page didn't change, so tried loading homepage, nada, have reset all plugins, still getting the issue.

    Edit: a quick git pull (1 deletion) & ./nodebb upgrade later and it seems to be ok, one of the plugins seems to be the cause. Trying to figure out which one.


  • Culprit seems to be plugin-emoji-extended, although I've no idea why. Enabling that plugin gives me the csrf error, disabling makes the error go away. 😕

  • Plugin & Theme Dev

    the first error seems to be my fault: #1517 sorry for that 🍰
    It appears within emoji-extended now because I recently updated to the new settings framework
    But I have no clue what the TypeError: Cannot read property '_csrf' of undefined is about... maybe it disappears when the first one is fixed.

  • Admin

    Just merged the above fix, let me know if your error is fixed after pulling latest


  • @psychobunny That's done the trick, no csrf error when enabling emoji-extended. 👍

Suggested Topics

  • 5
  • 6
  • 1
  • 6
  • 6
| |