In which version did Custom Javascript show up?



  • @baris I added that to the function, I see data being displayed. Is there anything specific I should be looking for? I could give you access to the forum (it is a dev forum not prod) if you wanted to poke on it directly.


  • Staff Admin

    If you see the data and if your <head> has the piwik.js file then I am not sure why it is not working.



  • @baris The odd thing is that it works in 1.4.5. Should it work if I move it to Custom Header with the script tags around it? Because when I try that I do get an error in the console and do NOT get any of that data form the console.log output.

    The error I get when it is in Custom Header is ReferenceError: Can't find variable: ajaxify


  • Staff Admin

    If you put it in custom header you need to wrap it in

    window.addEventListener('load', function () {
    // rest of the code
    });

    so it waits for the scripts to load otherwise ajaxify will be undefined.



  • @baris You lost me on that last post. What section do I wrap in window.addEventListener('load', function ()?


  • Staff Admin

    Everything. If you put it in custom header it should look like this

    <script>
    window.addEventListener('load', function () {
        var _paq = _paq || [];
        var u = "//your.piwikurlhere.com/";
    
        function firePiwik (data) {
            if (app.user && app.user.uid > 0) {
                _paq.push(['setUserId', app.user.uid.toString()]);
                _paq.push(['setCustomVariable', 1, "appUserUsername", app.user.username, "visit"]);
            }
            _paq.push(['setDocumentTitle', document.title]);
            _paq.push(['setCustomUrl', location.href]);
            _paq.push(['enableHeartBeatTimer']);
            _paq.push(['appendToTrackingUrl', 'bots=1']);
    		if (data.tpl === 'search') {
    			_paq.push(['trackSiteSearch', ajaxify.data.search_query,, ajaxify.data.matchCount]);
    		} else {
    			_paq.push(['trackPageView']);
    		}
            _paq.push(['enableLinkTracking']);
            _paq.push(['setTrackerUrl', u+'piwik.php']);
            _paq.push(['setSiteId', 1]);
        }
    
        var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
        g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'piwik.js'; s.parentNode.insertBefore(g,s);
    
        // added this line
        firePiwik(ajaxify.data);
    
        $(window).on('action:ajaxify.end', function(ev, data) {
            firePiwik(data);
        });
    });
    </script>
    


  • @baris I cannot get this to work. My new plan is to destroy my 1.12.1 version and install 1.6.x and test. If that works do the same going to version 1.7.x and test, and keep jumping forward until it doesn’t work and then report back.

    Thank you for all of your help thus far.



  • @baris. I reverted my dev site back to my production '1.4.5' version and it logged properly to Piwik (Matomo.). I upgraded to v1.6.1 and that version worked fine also, reporting to Piwik.

    I upgrade to v1.7.5 and voila reporting to Piwik no longer works. The 1.7.x branch is the one in which the Custom Javascript was broken out from Custom Header. I truly believe this is the root of the problem.

    Has anyone else reported oddities with custom javascript after the introduction of the 1.7 branch?

    Thank you.


  • Staff Admin

    We got a few reports of action:ajaxify.end not triggering since the scripts were moved to the footer but those are fixed by the code sample I showed.

    Maybe it has to do with the way the piwik script is being loaded. Can you try this in custom header instead.

    <script type="text/javascript" src="//your.piwikurlhere.com/piwik.js"></script>
    <script>
    window.addEventListener('load', function () {
        console.log(window.hasOwnProperty('_paq'))
        var _paq = _paq || [];
    
        function firePiwik (data) {
            if (app.user && app.user.uid > 0) {
                _paq.push(['setUserId', app.user.uid.toString()]);
                _paq.push(['setCustomVariable', 1, "appUserUsername", app.user.username, "visit"]);
            }
            _paq.push(['setDocumentTitle', document.title]);
            _paq.push(['setCustomUrl', location.href]);
            _paq.push(['enableHeartBeatTimer']);
            _paq.push(['appendToTrackingUrl', 'bots=1']);
    		if (data.tpl === 'search') {
    			_paq.push(['trackSiteSearch', ajaxify.data.search_query,, ajaxify.data.matchCount]);
    		} else {
    			_paq.push(['trackPageView']);
    		}
            _paq.push(['enableLinkTracking']);
            _paq.push(['setTrackerUrl', u+'piwik.php']);
            _paq.push(['setSiteId', 1]);
        }
    
        // added this line
        firePiwik(ajaxify.data);
    
        $(window).on('action:ajaxify.end', function(ev, data) {
            firePiwik(data);
        });
    });
    </script>
    

    Then check browser console to make sure piwik is properly loaded.



  • @baris Still no success. I am watching the web server logs of the Piwik server and I see a hit for the loading of "/piwik.js" (as I should as you call the URL in your first script tag but I don't see any further web server entries after that.

    I switch over to the my production NodeBB forum and while watching the Piwik web server log files I see all of the action I expect to see.

    Is there any sort of special widget or plugin I could install in which I could put this javascript and have it run as it should. I wonder what in NodeBB is stomping on it?

    I do see true in my browser console, from console.log(window.hasOwnProperty('_paq'))


  • Staff Admin

    @baris said in In which version did Custom Javascript show up?:

    _paq.push(['setTrackerUrl', u+'piwik.php']);

    Did you fix this to be _paq.push(['setTrackerUrl', '//your.piwikurlhere.com/piwik.php']); as well?

    If it doesn't work in custom header/javascript then I don't think it's gonna work in a widget either. You can try putting the same code in a global sidebar widget and test it.



  • @baris Thanks for all of the pointers. The javascript does not seem to work in a Widget, as you deduced, either.

    I'm at a loss as I'm not a JS programmer. I'll just stick with v1.4.5 for a while longer for my production forum. Possibly I will figure something else out.


Log in to reply
 

Suggested Topics

  • 3
  • 2
  • 4
  • 4
  • 9
| |