I can't install NodeBB on Ubuntu



  • I'm trying to install NodeBB for the last 10 hours. I'm a newbie about npm and linux stuff, but I know how to search and how to find answers, but that's my last try because I already tried everything I could.
    I was using Arch Linux and I was a little unhappy with it and then I moved to Ubuntu to test it and because I thought that would be easy like is on NodeBB docs.
    I tried so many things, but I couldn't pass through ./nodebb setup. But I still got this (I already tried to install sharp individually. I already tried to solve this problem by searching on sharp's github page):

    18955 verbose stack Error: sharp@0.22.0 install: `(node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)`
    18955 verbose stack Exit status 1
    18955 verbose stack     at EventEmitter.<anonymous> (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:301:16)
    18955 verbose stack     at EventEmitter.emit (events.js:196:13)
    18955 verbose stack     at ChildProcess.<anonymous> (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
    18955 verbose stack     at ChildProcess.emit (events.js:196:13)
    18955 verbose stack     at maybeClose (internal/child_process.js:1000:16)
    18955 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:267:5)
    18956 verbose pkgid sharp@0.22.0
    18957 verbose cwd /home/felipe/nodebb
    18958 verbose Linux 5.0.0-13-generic
    18959 verbose argv "/usr/bin/node" "/usr/bin/npm" "install" "--production"
    18960 verbose node v12.0.0
    18961 verbose npm  v6.9.0
    18962 error code ELIFECYCLE
    18963 error errno 1
    18964 error sharp@0.22.0 install: `(node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)`
    18964 error Exit status 1
    18965 error Failed at the sharp@0.22.0 install script.
    18965 error This is probably not a problem with npm. There is likely additional logging output above.
    18966 verbose exit [ 1, true ]
    

    I'm running Ubuntu 19.04;
    NodeBB v1.12.x (I already tried v1.11.x).
    Thank you.



  • Try latest master, node 12 was released recently and support for node 12 was added 4 days ago https://github.com/lovell/sharp/commits/master



  • I ran ./nodebb setup again and for my surprise I got that it was installed successfully (???). Then I answered the questions and finally I could ./nodebb start. But I tried to access it via http://localhost:4567/ and I got a "Unable to connect". Is this related to the sharp thing? If yes I'll try the latest master.

    Edit:
    Yes, it's. I got it using ./nodebb log



  • @baris Oh God, thank you. After a big journey to get here, finally I could see it working. I almost gave up. I appreciate your support.


Log in to reply
 

Suggested Topics

| |