400 bad request when accessing forum

Bug Reports

Suggested Topics

  • 0 Votes
    1 Posts

    I had this sometimes with v2, that some accounts would keep giving a warning that email wasnt validated
    Upgraded to v3 and it seems to be a bigger problem because you cant ever get past that message.
    For certain users the validation email never arrives to inbox or spam box.
    Todays example was with a gmail account, is that a known problem?

    Probably not related but theres a long list of errors in error log, here are first few, what might have caused this?
    /v1/timelines/public 890
    /v1/instance/peers 711
    /.well-known/host-meta 682
    /.well-known/webfinger 674
    /users/.well-known/webfinger 672
    /users/.well-known/host-meta 672
    /v1/instance 624
    /static/terms-of-service.html 376
    /wp-login.php 345
    /.env 316
    /ads.txt 261

  • 0 Votes
    4 Posts

    If it exhibits here only, then I have a gut feeling it is related to csrf-sync.

    If NodeBB restarts, it could be that the valid csrf token is stored in memory and is lost 🤷

    Edit: No... I just tested that locally and it worked fine. Hm.

  • 0 Votes
    8 Posts

    This is fixed on master now, the problem was a missing error callback here and some more error checking in the imgur plugin here

  • 0 Votes
    5 Posts


    When I go to a category page...


    After I touch on "New Topic"...

    IMG_0148.png ...

    After I touch topic title input...


  • 0 Votes
    29 Posts


    It was already dump.rdb so I left it that way. Restarted redis and still no forum.

    Could the directory structure be at fault? I didn't have the new redis at the location you pointed to, it was at /var/lib/redis/redis-2.8.9. (both redis.conf files point at dump.rdb by the way).

    EDIT: It's back now! You da' man. I'm still not sure which is the real redis.conf file though.