Overriding language json files from plugin



  • I have reviewed this older discussion:
    https://community.nodebb.org/topic/4647/how-to-override-language-login-json-file-through-plugin

    I have attempted to follow everything in the latest 1.11.1 , but I cannot make the language file override the existing file...

    Here is my basic setup

    Persona theme
    NodeBB 1.11.1
    My Plugin

    In my plugin.json I have added:

    "languages": "static/languages"
    

    In my plugin folder I have a folder:

    static/languages
    

    Inside this folder I have 1 folder only:

     en-US
    

    Inside this folder I have 1 file only:

    category.json
    

    This category.json was copied from the default nodebb base folder

    nodebb/public/language/en-US/category.json 
    

    To test if my plugin is overriding the default category.json included in the base I have updated the category.json my plugin/static/languages/en-US/category.json with the following:

     "new_topic_button": "HELLO WORLD!",
    

    I have re-built all assets and restarted the entire nodebb service.

    I have refreshed my browser and still the new_topic_button continues to show the old "New Topic" text.

    I am expecting "HELLO WORLD!"

    What am I doing wrong? How can my plugin update the text inside these language files?

    Thank you!


  • Global Moderator

    Is the plugin activated? Have you run ./nodebb build and restarted? Are you sure you're using the en-US language when you check?



  • I am using grunt for development, but i have fully killed the grunt watcher and have manually started up the ./nodebb build and made sure to fully kill and start up nodebb so it rebuilds all assets.... Still Its not using the language file.

    Where can I check the default nodebb language setting that is currently in use?



  • I might have found the issue....

    I see that my nodebb is defaulted to en-GB

    Let me switch this! One moment....



  • RESOLVED

    If anyone else sees this thread... Don't be the american who thinks the default should be en-US....

    It appears that the nodeBB default language was set for en-GB

    If you need to adjust the language default setting:

    Go to your NodeBB ACP (admin control panel) => General => Languages


Log in to reply
 

Suggested Topics

| |