Problems with login after upgrading to 1.11.0



  • After having installed 1.11.0 it appears an od thing when logging in.

    • I go to the https://nodebbs.mysite.com and the login page appears as normal.
    • Then I write my email and PW and clicks on the Log in -button
    • Then a red frame turns up saying "The page is missing" and provides a link to the first page and that link works, it takes me to the first page that looks like normal when being looged in.

    What is odd is that the page with the red frame and the text saying "The page is missing" has an URL like this

    https://nodebbs.mysite.com/https://nodebbs.mysite.com

    So the login button doubbled the URL !!! This must be a bug I suppose. Or ???


  • Admin

    Hm... this is odd, but something I did see before. What is the url value in your config.json? Does it match the URL you are using to access the site?



  • I have seen this bug(?) too. On my forum i am using Letsencrypt, so my forum is on https://....
    But in config.json i have http://...... Edit it to https:// solved the problem.

    Before version 1.11.0 i don't have this problem.



  • @FrankM said in Probmes with login after upgrading to 1.11.0:

    But in config.json i have http://...... Edit it to https:// solved the problem.
    Before version 1.11.0 i don't have this problem.

    Thanks, that solved the problem for me as well, changing http to https. And as for you, I did not have this problem before 1.11.0

    But then an other problem turned up: "Invalid CSRF Token"

    Pls see this link https://community.nodebb.org/topic/9222/invalid-csrf-token

    My solution for this was what is written in the end (I use Apache2)

    for the record for people finding this via search, for apache2 you have to set this somewhere in your nodebb vhost configuration
    with ssl

    RequestHeader set X-Forwarded-Proto "https"
    

    without ssl

    RequestHeader set X-Forwarded-Proto "http"
    

    you might have to enable mod_headers to do so!

    So upgrading to 1.11.0 gave me a problem that had to be solved in 2 steps. First by changing in config.json, then I had to modify Apache2 settings.


Log in to reply
 

Suggested Topics

  • 3
  • 6
  • 5
  • 7
  • 21
| |