Error after upgrading to 1.11.0 [Solved]



  • I tried my first upgrade today, to 1.11.0. I run

    $ git fetch # Grab the latest code from the NodeBB Repository
    $ git checkout v0.4.x # Type this as-is! Not v0.4.2 or v0.4.3, but "v0.4.x"!
    $ git merge origin/v0.4.x

    but when starting up it stops after a short while and the log gives:

    2018-12-05T12:35:30.710Z [19247] - error: listen EADDRINUSE: address already in use 0.0.0.0:4567
    Error: listen EADDRINUSE: address already in use 0.0.0.0:4567
    at Server.setupListenHandle [as _listen2] (net.js:1294:14)
    at listenInCluster (net.js:1342:12)
    at doListen (net.js:1480:7)
    at process.internalTickCallback (internal/process/next_tick.js:72:19) {"code":"EADDRINUSE","errno":"EADDRINUSE","syscall":"listen","address":"0.0.0.0","port":4567}
    2018-12-05T12:35:30.710Z [19247] - info: [app] Shutdown (SIGTERM/SIGINT) Initialised.
    3 restarts in 10 seconds, most likely an error on startup. Halting.

    What setting has changed to give this?
    Error: listen EADDRINUSE: address already in use 0.0.0.0:4567


  • Admin

    NodeBB is on version 1.1.0 so the command should use v1.1.x.

    That error means something is already running on that port, try stopping nodebb with ./nodebb stop and start again.



  • @baris

    Hi, Thank you, you are on the right track. I kept on searching and found a solution. Old processes where running so I had to kill them. Restart did not help.

    EADDRINUSE means that you already have NodeBB running. Use ps utility to find and kill it.

    Then

    ps aux|grep nodebb, then note the process Id and use kill -9 <said id>

    There were many prcesses running, so I found it easier just to restart the server. Now all is fine.

    Thank you anyhow.



  • @baris said in Error after upgrading to 1.11.0:

    NodeBB is on version 1.1.0 so the command should use v1.1.x.

    1.11.0 worked fine for me.


Log in to reply
 

Suggested Topics

| |