src/meta/minifier.js every minute



  • Launching htop, I see there is a proccess that repeat every minute aprox.

    /usr/bin/node /xxx/nodebb/src/meta/minifier.js
    

    I don't know if this causes default sound files disappear from dropdown combobox in ACP.

    NodeBB v1.11.0 upgraded from v1.10.2
    NodeJS: 10.x

    16fe1f83-0302-405b-973a-dd4fa6692abb-image.png

    fb75206b-99ac-47af-aaad-2f7abcd65782-image.png


  • Admin

    That is weird, the minifier should only be called when ./nodebb build is running. Will take a look into this.


  • Admin

    @Normando Are you running behind a reverse proxy or just accessing with port in url?



  • @baris I access through reverse proxy with nginx, on two ports because two server cores. Before with v1.10.2 runs perfect. If you need more info, let me know.

    Thanks


  • Admin

    When you stop and restart the forum do these minifiers start as well or are they coming after a while? It looks like the minifier is used when changing skins from the settings, see https://github.com/NodeBB/NodeBB/issues/7053



  • Restarting the forum (not rebuild), there is no minifier process. This comes after a while. This is the log file when restarting. As you can see, there are a few plugins with issues because v1.11.0 breaking changes. I don't know if these issues affect minifier behaviour.

    [cluster] Restarting...
    Clustering enabled: Spinning up 2 process(es).
    
    2018-12-04T14:41:24.232Z [8889] - info: [app] Shutdown (SIGTERM/SIGINT) Initialised.
    2018-12-04T14:41:24.243Z [8888] - info: [app] Shutdown (SIGTERM/SIGINT) Initialised.
    2018-12-04T14:41:24.251Z [8889] - info: [app] Web server closed to connections.
    2018-12-04T14:41:24.251Z [8889] - info: [app] Live analytics saved.
    2018-12-04T14:41:24.258Z [8889] - info: [app] Database connection closed.
    2018-12-04T14:41:24.258Z [8889] - info: [app] Shutdown complete.
    2018-12-04T14:41:24.298Z [8888] - info: [app] Web server closed to connections.
    2018-12-04T14:41:24.303Z [8888] - info: [app] Live analytics saved.
    [cluster] Child Process (8889) has exited (code: 0, signal: null)
    2018-12-04T14:41:24.321Z [8888] - info: [app] Database connection closed.
    2018-12-04T14:41:24.321Z [8888] - info: [app] Shutdown complete.
    [cluster] Child Process (8888) has exited (code: 0, signal: null)
    2018-12-04T14:41:25.271Z [24866] - info: Initializing NodeBB v1.11.0 https://vapeandoargentina.com.ar
    [benchpressjs] Unable to build or find a suitable native module, falling back to JS version
    [benchpressjs] Unable to build or find a suitable native module, falling back to JS version
    2018-12-04T14:41:34.718Z [24866] - warn: [upgrade/appendPluginScripts] Unable to read plugin.json for plugin `nodebb-plugin-youtube-lite`. Skipping.
    2018-12-04T14:41:34.720Z [24866] - warn: [upgrade/appendPluginScripts] Unable to read plugin.json for plugin `nodebb-plugin-gallery`. Skipping.
    2018-12-04T14:41:34.720Z [24866] - warn: [upgrade/appendPluginScripts] Unable to read plugin.json for plugin `nodebb-plugin-soundcloud`. Skipping.
    2018-12-04T14:41:34.721Z [24866] - warn: [upgrade/appendPluginScripts] Unable to read plugin.json for plugin `nodebb-plugin-videoplayer`. Skipping.
    2018-12-04T14:41:34.721Z [24866] - warn: [upgrade/appendPluginScripts] Unable to read plugin.json for plugin `nodebb-plugin-image-size`. Skipping.
    2018-12-04T14:41:34.722Z [24866] - warn: [upgrade/appendPluginScripts] Unable to read plugin.json for plugin `nodebb-plugin-emailer-local-0.7`. Skipping.
    2018-12-04T14:41:34.725Z [24867] - warn: [upgrade/appendPluginScripts] Unable to read plugin.json for plugin `nodebb-plugin-youtube-lite`. Skipping.
    2018-12-04T14:41:34.726Z [24867] - warn: [upgrade/appendPluginScripts] Unable to read plugin.json for plugin `nodebb-plugin-gallery`. Skipping.
    2018-12-04T14:41:34.727Z [24867] - warn: [upgrade/appendPluginScripts] Unable to read plugin.json for plugin `nodebb-plugin-soundcloud`. Skipping.
    2018-12-04T14:41:34.727Z [24867] - warn: [upgrade/appendPluginScripts] Unable to read plugin.json for plugin `nodebb-plugin-videoplayer`. Skipping.
    2018-12-04T14:41:34.727Z [24867] - warn: [upgrade/appendPluginScripts] Unable to read plugin.json for plugin `nodebb-plugin-image-size`. Skipping.
    2018-12-04T14:41:34.728Z [24867] - warn: [upgrade/appendPluginScripts] Unable to read plugin.json for plugin `nodebb-plugin-emailer-local-0.7`. Skipping.
    2018-12-04T14:41:37.750Z [24866] - info: [socket.io] Restricting access to origin: https://vapeandoargentina.com.ar:*
    2018-12-04T14:41:37.750Z [24867] - info: [socket.io] Restricting access to origin: https://vapeandoargentina.com.ar:*
    2018-12-04T14:41:39.602Z [24867] - warn: [plugins/require] Cannot find module './topics', please update your plugin!
    2018-12-04T14:41:39.602Z [24866] - warn: [plugins/require] Cannot find module './topics', please update your plugin!
        at /opt/vapor/nodebb/node_modules/nodebb-plugin-highlights/library.js:7:29
        at /opt/vapor/nodebb/node_modules/nodebb-plugin-highlights/library.js:7:29
    2018-12-04T14:41:39.603Z [24866] - warn: [plugins/require] Cannot find module './user', please update your plugin!
        at /opt/vapor/nodebb/node_modules/nodebb-plugin-highlights/library.js:8:25
    2018-12-04T14:41:39.603Z [24867] - warn: [plugins/require] Cannot find module './user', please update your plugin!
        at /opt/vapor/nodebb/node_modules/nodebb-plugin-highlights/library.js:8:25
    2018-12-04T14:41:39.838Z [24867] - warn: [plugins/require] Cannot find module './settings', please update your plugin!
    2018-12-04T14:41:39.839Z [24866] - warn: [plugins/require] Cannot find module './settings', please update your plugin!
        at /opt/vapor/nodebb/node_modules/nodebb-plugin-imgbed/library.js:9:32
        at /opt/vapor/nodebb/node_modules/nodebb-plugin-imgbed/library.js:9:32
    2018-12-04T14:41:39.839Z [24866] - warn: [plugins/require] Cannot find module './posts/cache', please update your plugin!
        at /opt/vapor/nodebb/node_modules/nodebb-plugin-imgbed/library.js:10:29
    2018-12-04T14:41:39.839Z [24866] - warn: [plugins/require] Cannot find module './socket.io/admin', please update your plugin!
    2018-12-04T14:41:39.839Z [24867] - warn: [plugins/require] Cannot find module './posts/cache', please update your plugin!
        at /opt/vapor/nodebb/node_modules/nodebb-plugin-imgbed/library.js:11:35
        at /opt/vapor/nodebb/node_modules/nodebb-plugin-imgbed/library.js:10:29
    2018-12-04T14:41:39.840Z [24867] - warn: [plugins/require] Cannot find module './socket.io/admin', please update your plugin!
        at /opt/vapor/nodebb/node_modules/nodebb-plugin-imgbed/library.js:11:35
    2018-12-04T14:41:39.876Z [24866] - warn: [plugins/require] Cannot find module './posts/cache', please update your plugin!
        at Object.<anonymous> (/opt/vapor/nodebb/node_modules/nodebb-plugin-iframely/library.js:11:31)
    2018-12-04T14:41:39.877Z [24867] - warn: [plugins/require] Cannot find module './posts/cache', please update your plugin!
        at Object.<anonymous> (/opt/vapor/nodebb/node_modules/nodebb-plugin-iframely/library.js:11:31)
    
    2018-12-04T14:41:40.832Z [24866] - warn: [plugins/load] The following plugins may not be compatible with your version of NodeBB. This may cause unintended behaviour or crashing. In the event of an unresponsive NodeBB caused by this plugin, run `./nodebb reset -p PLUGINNAME` to disable it.
      * nodebb-theme-va
    
    2018-12-04T14:41:40.896Z [24867] - warn: [plugins/require] Cannot find module './database', please update your plugin!
        at Object.YoutubeLite.init [as method] (/opt/vapor/nodebb/node_modules/nodebb-plugin-youtube-embed/library.js:20:22)
    2018-12-04T14:41:40.897Z [24866] - warn: [plugins/require] Cannot find module './database', please update your plugin!
        at Object.YoutubeLite.init [as method] (/opt/vapor/nodebb/node_modules/nodebb-plugin-youtube-embed/library.js:20:22)
    info: Imgbed: regex recompiled: (?<url>https?:\/\/[^\s]+\/(?<filename>[\w_0-9\-\.]+\.(jpg|jpeg|gif|gifv|png|svg))([^\s]*)?)
    info: Imgbed: cache initialized to size 3
    info: Imgbed: regex recompiled: (?<url>https?:\/\/[^\s]+\/(?<filename>[\w_0-9\-\.]+\.(jpg|jpeg|gif|gifv|png|svg))([^\s]*)?)
    info: Imgbed: cache initialized to size 3
    2018-12-04T14:41:40.965Z [24866] - info: [plugins/spam-be-gone] Settings loaded
    2018-12-04T14:41:40.966Z [24867] - info: [plugins/spam-be-gone] Settings loaded
    2018-12-04T14:41:41.045Z [24867] - info: Routes added
    2018-12-04T14:41:41.048Z [24867] - info: NodeBB Ready
    2018-12-04T14:41:41.051Z [24867] - info: Enabling 'trust proxy'
    2018-12-04T14:41:41.053Z [24866] - info: Routes added
    2018-12-04T14:41:41.054Z [24867] - info: NodeBB is now listening on: 0.0.0.0:20001
    2018-12-04T14:41:41.056Z [24866] - info: NodeBB Ready
    2018-12-04T14:41:41.058Z [24866] - info: Enabling 'trust proxy'
    2018-12-04T14:41:41.061Z [24866] - info: NodeBB is now listening on: 0.0.0.0:20000
    

  • Community Rep

    @Normando I pushed an update for imgbed (1.0.3) a few days ago, did your issue resolve?



  • @Bri hello. I was not updated because "Out of Date" plugins shows 0. Recently I was update iframely plugin, but imgbed till 1.0.2. Maybe something with npm repository?

    Thanks Bri



  • opssss... I see the updated package in npmjs.com to 1.0.3. Strange why not shows me in ACP.


  • Community Rep

    Yeah I saw this happen to me as well. Not sure why... When i went through updating my forum though, the ./nodebb upgrade step caught it.

    I've since published 1.1.0 which upgrades the dependencies to something more recent, and less vulnerable. Apparently npm audit caught it but snyk didn't... 😕


 

Suggested Topics

| |