nodebb-plugin-ns-embed don't work with v1.11.0



  • Since v1.11.0 i got these errors

    018-11-29T21:09:16.917Z [13756] - warn: [plugins/require] Cannot find module './src/emitter', please update your plugin!
        at /nodebb/node_modules/nodebb-plugin-ns-embed/plugin/nodebb.js:8:31
    2018-11-29T21:09:16.917Z [13756] - error: Error: Cannot find module './src/emitter'
        at Function.Module._resolveFilename (module.js:548:15)
        at Function.Module._load (module.js:475:25)
        at Module.require (module.js:597:17)
        at require (internal/module.js:11:18)
        at Module.require.main.require (/nodebb/require-main.js:8:10)
        at /nodebb/node_modules/nodebb-plugin-ns-embed/plugin/nodebb.js:8:31
        at Object.<anonymous> (/nodebb/node_modules/nodebb-plugin-ns-embed/plugin/nodebb.js:44:3)
        at Module._compile (module.js:653:30)
        at Object.Module._extensions..js (module.js:664:10)
        at Module.load (module.js:566:32)
        at tryModuleLoad (module.js:506:12)
        at Function.Module._load (module.js:498:3)
        at Module.require (module.js:597:17)
        at require (internal/module.js:11:18)
        at /nodebb/node_modules/nodebb-plugin-ns-embed/plugin/database.js:10:24
        at Object.<anonymous> (/nodebb/node_modules/nodebb-plugin-ns-embed/plugin/database.js:74:3)
    2018-11-29T21:09:16.917Z [13756] - warn: [plugins] Unable to parse library for: nodebb-plugin-ns-embed
    

    Can i fix this?


  • Admin

    Fixed here https://github.com/NicolasSiver/nodebb-plugin-ns-embed/pull/13, the author has to merge and publish a new version.



  • Problem solved with version 3.


Log in to reply
 

Suggested Topics

| |