Facebook sso - essentials



  • hi,
    i am getting into the 'insecure page' error (Insecure Login Blocked: You can't get an access token or log in to this app from an insecure page. Try re-loading the page as https://).

    my setup: nodebb 1.10, latest, behind apache.

    in the config.json url i am using a http://url to which my apache proxy points too. i can't obviously change it to https but how to make the facebook plugin using now the real outer url of my apache server which runs the https perfectly ? the plugin is creating a wrong redirect_url,...

    that all makes no sense, i spent the whole day now bouncing my head against this...

    thanks,

    i already tried all the suggested settings here from the forum,...


  • Admin

    You should set the url in your config.json to use https, the SSO plugin probably uses the url value from config.json.



  • yeah, i tried that too, https://myurl.com:4567 renders the forum inaccessible since it doesn't return encrypted http, obviously.



  • This post is deleted!


  • @Macrow-Willson said in Facebook sso - essentials:

    yeah, i tried that too, https://myurl.com:4567 renders the forum inaccessible since it doesn't return encrypted http, obviously.

    Not really obviously. The URL in your config.json should be the one you're using publicly. Thus whatever your Apache reverse proxy is configured for. The configuration is used to create the URLs on your site. It has no impact on the actual communication with your reverse proxy.

    My hunch is, you also need to remove that port. Because your Apache reverse proxy probably is providing your site over the standard HTTPS port. So it probably is just https://myurl.com. Also don't change anything about your reverse proxy configuration when you change this url parameter. Your reverse proxy still fetches the forum over HTTP at the port 4567. This has nothing to do with the url parameter.


 

| |