Nodebb Running but Blank Page



  • Hi.. something happend to my mongodb (3.4) instance and I took the change to upgrade it.

    I'm running mongo 3.6.5 and the nodebb upgrade process was fine BUT when I try to start it... the main page is all blank and I get this stack trace on the logs

    mongo 3.6.5
    node 8.6.0
    npm 5.8.0
    nobdebb - 1.9.x branch

    Already remove all the modules and installed them again.. no use. What should I do?

    2018-06-25T18:50:25.290Z [28554] - error: /category/2.rss
     Error: [[error:invalid-cid]]
        at async.waterfall.category.topics (/home/forum/NodeBB/src/categories.js:35:17)
        at nextTask (/home/forum/NodeBB/node_modules/async/dist/async.js:5310:14)
        at next (/home/forum/NodeBB/node_modules/async/dist/async.js:5317:9)
        at /home/forum/NodeBB/node_modules/async/dist/async.js:958:16
        at /home/forum/NodeBB/node_modules/async/dist/async.js:473:16
        at next (/home/forum/NodeBB/node_modules/async/dist/async.js:5315:29)
        at /home/forum/NodeBB/node_modules/async/dist/async.js:958:16
        at /home/forum/NodeBB/src/categories.js:164:4
        at nextTask (/home/forum/NodeBB/node_modules/async/dist/async.js:5310:14)
        at next (/home/forum/NodeBB/node_modules/async/dist/async.js:5317:9)
        at /home/forum/NodeBB/node_modules/async/dist/async.js:958:16
        at /home/forum/NodeBB/node_modules/async/dist/async.js:3874:9
        at /home/forum/NodeBB/node_modules/async/dist/async.js:473:16
        at iterateeCallback (/home/forum/NodeBB/node_modules/async/dist/async.js:980:24)
        at /home/forum/NodeBB/node_modules/async/dist/async.js:958:16
        at /home/forum/NodeBB/node_modules/async/dist/async.js:3871:


  • Seems like there is a connection pending when I acess the page.:

    Request URL: ws://xxx.com.br/socket.io/?EIO=3&transport=websocket&sid=Tl9h8GZdwQoAKtX-AABq
    Request Method: GET
    Status Code: 101 Switching Protocols



  • If your home page is blank your database might not have the forum data. Check the database name from config.json and then connect to mongodb and make sure the data is there.



  • yeah.. for some reason..... the crash made my DB go empty...................... SO LUCKy!!!! and had forgotten to enable automatic backups.. life is good 🙂



  • Please first check the data storage directories of your MongoDB. While doing some crazy tests and more or less intentionally made the MongoDB go crash I found at times that it "forgot" about the available data, even though there were still kind of big files probably with all the data. I don't know how to recover from there but I assume there would be some articles out there in the internet helping you with it.

    But yeah, mongodump, borg backup, lftp synchronize to remote drive (or similar). Every day. And if you're at it, make sure the backups on your local computer are working as intended as well 😉


Log in to reply
 

Suggested Topics

| |