Cant setup or build on new Ubuntu 16.04 server



  • Trying to migrate my installation (https://9854.moe) to a external server and it will not build or compete the setup. It always gets stuck here

    2018-03-06T21:36:00.452Z [6903] - info: NodeBB Setup Triggered via Command Line
    
    Welcome to NodeBB v1.7.5!
    
    This looks like a new installation, so you'll have to answer a few questions about your environment before we can proceed.
    Press enter to accept the default setting (shown in brackets).
    2018-03-06T21:36:00.520Z [6903] - info:
    Now configuring mongo database:
    2018-03-06T21:36:00.757Z [6903] - info: [database] Checking database indices.
    2018-03-06T21:36:00.764Z [6903] - info: [database] Checking database indices done!
    Configuration Saved OK
    Populating database with default configs, if not already set...
    2018-03-06T21:36:01.934Z [6903] - warn: [cache-buster] could not read cache buster Error: ENOENT: no such file or directory, open '/home/winterchan/nodebb/build/cache-buster'
    Previous theme detected, skipping enabling default theme
    Categories OK. Found 29 categories.
    Administrator found, skipping Admin setup
    2018-03-06T21:36:02.031Z [6903] - info: Global Moderators group found, skipping creation!
    Enabling default plugins
    2018-03-06T21:36:02.045Z [6903] - info: [install/defaultPlugins] customDefaults
    2018-03-06T21:36:02.045Z [6903] - info: [install/enableDefaultPlugins] activating default plugins 0=nodebb-plugin-composer-default, 1=nodebb-plugin-markdown, 2=nodebb-plugin-mentions, 3=nodebb-widget-essentials, 4=nodebb-rewards-essentials, 5=nodebb-plugin-soundpack-default, 6=nodebb-plugin-emoji, 7=nodebb-plugin-emoji-android
    2018-03-06T21:36:02.072Z [6903] - warn: [upgrade/appendPluginScripts] Unable to read plugin.json for plugin `nodebb-plugin-soundpack-aosp`. Skipping.
      started
    2018-03-06T21:36:02.136Z [6903] - info: [build] Building in parallel mode
    2018-03-06T21:36:02.137Z [6903] - info: [build]         plugin static dirs  build started
    2018-03-06T21:36:02.140Z [6903] - info: [build]          requirejs modules  build started
    2018-03-06T21:36:02.141Z [6903] - info: [build]           client js bundle  build started
    2018-03-06T21:36:02.148Z [6903] - info: [build]            admin js bundle  build started
    2018-03-06T21:36:02.150Z [6903] - info: [build]         client side styles  build started
    2018-03-06T21:36:02.151Z [6903] - info: [build] admin control panel styles  build started
    2018-03-06T21:36:02.152Z [6903] - info: [build]                  templates  build started
    2018-03-06T21:36:02.153Z [6903] - info: [build]                  languages  build started
    2018-03-06T21:36:02.154Z [6903] - info: [build]                     sounds  build started
    Killed
    

    I dont know where "Killed" is coming from but i have tried making a whole new install and same result


  • Admin

    How much memory does your server have? Do you have swap setup?



  • @baris 512 MB and no swap. The server is from Vultr
    My current server is 512 MB with 512 MB Swap. That server is a VMware VM on my ESXi Server


  • Admin

    Try setting some swap, the build process can consume more than 512mb memory and that would cause the process to be killed.



  • @baris That seems to have solved it, Thanks a lot.


 

| |