Problem with images

Technical Support
  • Hello,
    First, thanks for your work. It's an extraordinary work you do, so keep doing that 😉

    But, I've a little problem :
    Users upload images, but only connected users can see these images. Guests can't see these images. It's quite strange. And when I click on "open the image on a new tab" where there is normally the image, I get an error on a blank page : "not-allowed".
    It's really strange... I was thinking of a permission error. Can you help me pls ? I already tried chmod 775, 755 and 777 on upload folder and it didn't work.

    Software version : v1.7.0
    Type : Selfhosting.
    Server software : Nginx.
    Service Managing software : systemd

  • In your ACP config, do you have "Make uploaded files private" enabled? It's under Settings -> Posts

  • In Settings -> Post, I don't have this option... it's weird. In fact I've nothing related to upload. Thanks anyway. Perhaps there is a config file I can change in my folder ?

    In the content summary of Settings -> Post, I have :

    Post Sorting
    Posting Restrictions
    Unread Settings
    Recent Settings
    Signature Settings
    Composer Settings
    IP Tracking
  • Good, I found it !
    Thanks you very much !

    (it was in Settings -> Uploads)

Suggested Topics