NodeBB v1.0.3 won't start, error: undefined

Technical Support
  • Trying to run NodeBB v1.0.3 for myBB to NodeBB transition and unable to start NodeBB. Here is what I have:

    • Node.js v4.2.2
    • Redis server v=3.2.6
    • NodeBB v1.0.3

    NodeBB installs fine, without errors but I get this message when running ./nodebb log:

    8/10 02:56 [2458] - info: Time: Sun Oct 08 2017 02:56:28 GMT+0300 (MSK)
    8/10 02:56 [2458] - info: Initializing NodeBB v1.0.3
    8/10 02:56 [2458] - info: [plugins/emoji-one] Initial startup detected. Downloading emojione assets...
    8/10 02:56 [2458] - error: 
    8/10 02:56 [2458] - info: [app] Shutdown (SIGTERM/SIGINT) Initialised.
    8/10 02:56 [2458] - info: [app] Database connection closed.
    8/10 02:56 [2458] - info: [app] Web server closed to connections.
    8/10 02:56 [2458] - info: [app] Shutdown complete.
    3 restarts in 10 seconds, most likely an error on startup. Halting.
  • @h7 tried on a different Debian 7 (Wheezy) server, to make sure this is a common issue:

    • Node.js v4.2.2
    • Redis server v=3.2.11
    • NodeBB v1.0.3

    NodeBB installs again, without errors but the log comes back with the exact same [2458] - error: undefined

    npm rm nodebb-plugin-emoji-one
    npm install [email protected]

    fixed that error, now:

    info: Time: Sun Oct 08 2017 04:59:32 GMT+0300 (MSK)
    info: Initializing NodeBB v1.0.3
    [outdated] nodebb-plugin-emoji-one installed v1.1.4, package.json requires 1.1.0
    warn: One or more of NodeBB's dependent packages are out-of-date. Please run the following command to update them:
    warn:     ./nodebb upgrade
    [cluster] Child Process (6503) has exited (code: 0, signal: null)

    OK, removing the plugin npm rm nodebb-plugin-emoji-one and ./nodebb start worked, NodeBB v1.0.3 running, still can't log-in:

    warn: [meta/dependencies] Bundled plugin nodebb-plugin-emoji-one not found, skipping dependency check.
    [minifier] file not found, node_modules/
    [minifier] file not found, node_modules/
    info: NodeBB Ready
    info: Enabling 'trust proxy'
    info: NodeBB is now listening on:
    error: /login invalid csrf token
    error: /login invalid csrf token

    using older versions of

    npm remove
    npm remove
    npm install [email protected]
    npm install [email protected]

    did the trick, NodeBB v1.0.3 running and ready for myBB to NodeBB transition

Suggested Topics

  • Can't get Nginx to work

    Technical Support
    0 Votes
    7 Posts

    @PitaJ said in Can't get Nginx to work:

    @Goldrush12 said in Can't get Nginx to work:

    I just tried that without success (yes, I made sure to restart NodeBB). Also, the developer mode doesn't fix the problem (contrary to what's stated in the linked thread).

    Okay, so it must be something else.

    I'm not sure if this has anything to do with the issue, but I had a few errors while setting up NodeBB initially, which I had to address.

    Wow, um, big red flag there. How did you install NodeBB in the first place? It may be wise to start from scratch and reinstall with correct permissions from the get-go. You absolutely should not use sudo to install or run NodeBB. The only installation-related things you need root access for are nginx configuration and maybe changing directory privileges before installing NodeBB.

    What OS are you installing NodeBB on? Are you following any tutorials or instructions?

    My OS is Ubuntu 18.04 and I followed a documentation from your website. I started from scratch and it's running fine now! I assume the guide I used must have been outdated, which led to some errors. I must say that it might make sense to clean up the documentary and make sure that only one version of the installation guide for every OS exists to avoid confusion.

    Thank you for your help! 🙂

  • How can I install NodeBB?

    Technical Support
    0 Votes
    5 Posts

    Hello there!

    NodeBB is designed to work best under a virtual private server. Using a traditional hosting service is not recommended as they do not have the capabilities to power NodeBB effectively.

    The code and instructions can be found here at our project repository Full instructions can be found in our Documentation Portal We recommend DigitalOcean to host your NodeBB, you'll get a month free just by registering with this link. You can also try applying the 10TOSHIP coupon to get another two months free, and as an added bonus, you'll be helping us out too!

    Thank you for your interest in NodeBB!

  • 0 Votes
    8 Posts

    @Giggiux That is correct. It will keep restarting until mongo/redis has started. I added mongod.service in the After parameter and does startup normally. I know mongod takes a minute or 2 to start, as I have tested this and nodebb is in the failed state until mongod has fully started. Sometimes mongod will show that it has started but nodebb fails to start. I just waited a couple of minutes and checked nodebb again (systemctl status nodebb) and it was up/active, without my intervention 🙂

  • 0 Votes
    2 Posts

    First of all your NGINX config is incorrect. You want to access the forum under /community, but are using /forum in it.
    This is a simplified version of my NGINX config:

    And here my config.json:

  • 0 Votes
    8 Posts

    @ngsankar Thank you very much. these steps worked, after I struggled with other guides for 2 days. Though I am stuck with old Ubuntu version