NodeBB v1.0.3 won't start, error: undefined



  • Trying to run NodeBB v1.0.3 for myBB to NodeBB transition and unable to start NodeBB. Here is what I have:

    • Node.js v4.2.2
    • Redis server v=3.2.6
    • NodeBB v1.0.3

    NodeBB installs fine, without errors but I get this message when running ./nodebb log:

    8/10 02:56 [2458] - info: Time: Sun Oct 08 2017 02:56:28 GMT+0300 (MSK)
    8/10 02:56 [2458] - info: Initializing NodeBB v1.0.3
    8/10 02:56 [2458] - info: [plugins/emoji-one] Initial startup detected. Downloading emojione assets...
    8/10 02:56 [2458] - error: 
    undefined
    8/10 02:56 [2458] - info: [app] Shutdown (SIGTERM/SIGINT) Initialised.
    8/10 02:56 [2458] - info: [app] Database connection closed.
    8/10 02:56 [2458] - info: [app] Web server closed to connections.
    8/10 02:56 [2458] - info: [app] Shutdown complete.
    3 restarts in 10 seconds, most likely an error on startup. Halting.
    


  • @h7 tried on a different Debian 7 (Wheezy) server, to make sure this is a common issue:

    • Node.js v4.2.2
    • Redis server v=3.2.11
    • NodeBB v1.0.3

    NodeBB installs again, without errors but the log comes back with the exact same [2458] - error: undefined

    npm rm nodebb-plugin-emoji-one
    npm install nodebb-plugin-emoji-one@1.1.4
    

    fixed that error, now:

    info: Time: Sun Oct 08 2017 04:59:32 GMT+0300 (MSK)
    info: Initializing NodeBB v1.0.3
    [outdated] nodebb-plugin-emoji-one installed v1.1.4, package.json requires 1.1.0
    warn: One or more of NodeBB's dependent packages are out-of-date. Please run the following command to update them:
    warn:     ./nodebb upgrade
    [cluster] Child Process (6503) has exited (code: 0, signal: null)
    

    OK, removing the plugin npm rm nodebb-plugin-emoji-one and ./nodebb start worked, NodeBB v1.0.3 running, still can't log-in:

    warn: [meta/dependencies] Bundled plugin nodebb-plugin-emoji-one not found, skipping dependency check.
    [minifier] file not found, node_modules/socket.io-client/socket.io.js
    [minifier] file not found, node_modules/socket.io-client/socket.io.js
    info: NodeBB Ready
    info: Enabling 'trust proxy'
    info: NodeBB is now listening on: 0.0.0.0:4567
    error: /login invalid csrf token
    error: /login invalid csrf token
    

    using older versions of socket.io:

    npm remove socket.io
    npm remove socket.io-client
    
    npm install socket.io@1.4.8
    npm install socket.io-client@1.4.0
    

    did the trick, NodeBB v1.0.3 running and ready for myBB to NodeBB transition


Log in to reply
 


Star

Looks like your connection to NodeBB was lost, please wait while we try to reconnect.