Sidebar vanished, Lavender theme

  • Admin

    haha. Where's the faith @planner!

    nyancat.png


  • @psychobunny

    Cool! Very cool!!

  • Admin

    personally I would have been pretty upset if you didn't think it was cool 😛


  • @psychobunny

    Yeah, considering that I almost got excommunicated for harping on sidebars.

  • GNU/Linux Admin

    It's ok @planner, without you, we'd still be developing on a NodeBB without sidebars *shudder*.


  • I fixed this, I had to rerun upgrade and reset and reactivate all plugins after redumping the db. My bad for not trying it that way before.

    I still get a small bug in admin panel. When I delete a user it doesn't remove it from the display, I have to reload the page.

  • GNU/Linux Admin


  • @julian that one looks great actually.


  • today i upgraded to 4.0.0 and i have the same issue, plus content not loading when i click menus in admin
    i tried to reset and rerun upgrade, this is still not working and i see this error in console

    firefox could not establish a connection to server ws://forum.xxxxxxxx.com/socket.io/1/websocket/GzrMxZ8uYBdQX12C21GS. (socket.io.js:2)
    utils.makeNumbersHumanReadable is not a function (app.js:287)


  • utils.makeNumbersHumanReadable is not a function (app.js:287)

    ctrl+f5 (after several times) solved the .js issue (content not loading in admin), but only in the admin
    the forum index still does not display the homepage sidebar, but if i put some widgets in global sidebar they will be displayed

    and why after a reset i still have all plugins on? i am using lavender theme.

  • GNU/Linux Admin

    @manuel Could you try the latest version of NodeBB (or if you're on v0.4.x branch, update the code in that branch), and run ./nodebb upgrade again?

    Please run this command and let me know what it says: npm ls nodebb-widget-essentials nodebb-theme-vanilla nodebb-theme-lavender


  • @julian said:

    @manuel Could you try the latest version of NodeBB (or if you're on v0.4.x branch, update the code in that branch), and run ./nodebb upgrade again?

    Please run this command and let me know what it says: npm ls nodebb-widget-essentials nodebb-theme-vanilla nodebb-theme-lavender

    ./nodebb stop --> ./nodebb line 31: kill (no such process)

    git pull + nodebb upgrade says i have all up to date

    nodebb@0.4.0 with lavender 0.0.25-0, vanilla 0.0.19-1, widgets-essentials 0.0.21-0

    starting in log mode:
    some plugins are using the deprecated "callbacked" method

    plugins are marked as deactivated in admin but i can see on forum that emoji, twitter, soundcloud are working like if they are active O.o

    the homepage and category sidebars lost theyr widgets that are now gone in drafts sidebar
    there are some issues dragging them (they are positioned away from mouse pointer while dragging)
    after reconfiguring and saving sidebars it's still not displayed in the homepage and plus the theme is not "running smoothly" and there are some bad looking things (like up/down votes)

    i tried switching from firefox 30 to chrome, same situation and same error in websocket connection

    i think i have to downgrade to previous version 😞

  • Plugin & Theme Dev Anime Lovers GNU/Linux

    @anooxy I tried, I guess it was a bug.

  • GNU/Linux Admin

    @manuel Sounds like you have an existing NodeBB process running. Make sure there are no orphaned NodeBBs running!

    ps aux | grep node, and then kill -9 with impunity.


  • @julian said:

    @manuel Sounds like you have an existing NodeBB process running. Make sure there are no orphaned NodeBBs running!

    ps aux | grep node, and then kill -9 with impunity.

    after killing and restarting everything i have this js error in admin

    Error: script error for: alerts (require.js:8)

    same for the path forum/admin/ loggers|database|events and forum/admin/plugins/ nameplugin

    some plugins like local emailer and shoutbox won't work in admin

    i still can't see the sidebar in homepage and moreover while navigating through forum when i go back to the home nothing will be loaded (or better, categories are invisible O.o)

    i cannot change theme from lavender to vanilla i.e. O.o


  • when content is not displayed i can see this error in js console

    t.match is not a function (nodebb.min.js:9)

    this will get me mad... need to downgrade


  • When you start NodeBB check your logs. If it says your redis schema is not up to date do a:

    node app --upgrade
    
  • GNU/Linux Admin

    @manuel, please try the following:

    $ cd /path/to/nodebb
    $ ./nodebb stop
    $ git fetch
    $ git checkout v0.4.x
    $ ./nodebb upgrade
    $ ./nodebb start   # or "./nodebb dev" for interactive output
    

  • @julian said:

    @manuel, please try the following:

    $ cd /path/to/nodebb
    $ ./nodebb stop
    $ git fetch
    $ git checkout v0.4.x
    $ ./nodebb upgrade
    $ ./nodebb start   # or "./nodebb dev" for interactive output
    

    note that before running your commands i was on master branch, git-pulled and ./nodebb upgraded without errors
    then i tried to checkout to 0.3.2 to go back but without good results
    and now with your instructions i get this:

    npm http GET https://registry.npmjs.org/marked/0.3.2
    npm http 304 https://registry.npmjs.org/marked/0.3.2

    npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport-google-oauth/node_modules/passport-oauth requires passport@'~0.1.1' but will load
    npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport,
    npm WARN unmet dependency which is version 0.2.0
    npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport-facebook/node_modules/passport-oauth requires passport@'~0.1.1' but will load
    npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport,
    npm WARN unmet dependency which is version 0.2.0
    npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport-twitter/node_modules/passport-oauth requires passport@'~0.1.1' but will load
    npm WARN unmet dependency /home/manuel/nodebb/node_modules/passport,
    npm WARN unmet dependency which is version 0.2.0

    error: [upgrade] NodeBB upgrade could not complete, as your database schema is too far out of date.
    error: [upgrade] Please ensure that you did not skip any minor version upgrades.
    error: [upgrade] (e.g. v0.1.x directly to v0.3.x)

    ...but it's impossible that i have downgraded db schema O.o

    i tried switching back to 0.3.x and re run upgrade, as suggested here but i have still the same error upgrading from 0.3 to 0.4

  • GNU/Linux Admin

    If you get that error on the v0.3.x branch, then you need to switch to the v0.2.x branch, and run the following (note that these commands differ only because they are from a very old version of NodeBB):

    $ git checkout v0.2.x
    $ rm -rf node_modules
    $ npm install
    $ node app --upgrade
    $ git checkout v0.3.x
    $ npm install
    $ ./nodebb upgrade
    $ git checkout v0.4.x
    $ ./nodebb upgrade
    

Suggested Topics

| |