No mailer plugins show config page, at all



  • I have tried every single mailer plugin, and enabled, and activated, and restarted/reloaded nodebb, yet I still cannot see the plugins configuration page at all.

    no matter which plugin I use for mailing.

    Please advise.

    This is all I see in the plugins drop down. No matter what I do, and I'm fairly dev savvy. I have tried 3 different mailer plugins, but nothing ever shows up in plugins config list.


  • Global Moderator

    What version of NodeBB? What version of the emailer plugins? Are there any errors in the log?

    Were you trying to have multiple emailer plugins active at the same time?



  • Hello PitaJ, thanks for a prompt response.

    I just came by to post an Update: I had given up until I got a reply from the gurus here, but then I discovered that I had closed my browser, restarted it, and apparently it started to show the new plugins in the config menu. That is strange.

    What can I do to test further if it his a front-end updating issue or something?

    Thank you, if the post (and another I commented on during my search clutter up, feel free to delete)

    I also read that on the blog you have stated since 0.9 or something, mailing is built into the nodebb program. I was trying to search more about this in the documentation but have not yet landed upon it.

    If it's not much trouble, could you tell me about this? I would like to get email working with the best advised method. Thank you.

    NOTE: I did not attempt to have multiple plugins on at the same time, as I didn' think it would be appropriate. It might cause issues, so I only kept one at a time and tested one at a time.



  • I think I may have finally pointed it down to:

    After installing plugin, one must restart nodebb, then one must log out, then log back in, otherwise the menu doesn't show.



  • Also, I use zohomail, which uses uses ssl or TLS, which mailer plugin would you recommend?


  • Plugin & Theme Dev

    @Hash-Borgir said in No mailer plugins show config page, at all:

    then one must log out, then log back in, otherwise the menu doesn't show

    Not required. Just restart and refresh the page after the restart is complete.


Log in to reply
 

Looks like your connection to NodeBB was lost, please wait while we try to reconnect.