fresh install after system reboot nodebb blank page



  • Hello,

    I managed to install nodebb with below configurations and it is working like a charm now. But if i REBOOT my vps, when i go to my forum page i can't see default categories anymore there are only nodebb logo and login and register buttons but they don't work also.

    *nodebb working on unix socket,
    *redis server working on unix socket,
    */opt/nodebb chowned by nodebb user,
    *i started nodebb by nodebb user, not as root with ./nodebb start
    *i didn't implement any upstart, forever or Supervisor rules
    *i didn't add nodebb to systemd for auto-start (/lib/systemd/system/nodebb.service)

    my config.json;

    {
        "url": "https://forum.mydomain.com/",
        "port": "/tmp/nodebb.sock",
        "secret": "145a922f----------------------",
        "database": "redis",
        "redis": {
            "host": "/tmp/redis.sock",
            "password": "longlongpass",
            "database": "0"
        }
    }
    
    

    My proxy settings; maybe this helps someone | apache 2.4+ | while nodebb on unix domain socket.

    ProxyRequests off
    
    SSLProxyEngine On
    RequestHeader set X-Forwarded-Proto "https"
    RewriteEngine On
    RewriteCond %{REQUEST_URI}  ^/socket.io            [NC]
    RewriteCond %{QUERY_STRING} transport=websocket    [NC]
    RewriteRule /(.*)           ws://127.0.0.1:4567/$1 [P,L]
    ProxyPass / unix:/tmp/nodebb.sock|http://127.0.0.1/
    ProxyPassReverse / unix:/tmp/nodebb.sock|http://127.0.0.1/
    

    Thanks in advance.


  • Admin

    Seems like Redis is not installed properly, and is not saving to disk.

    Check redis logs for errors.



  • Yes, you are right, thank you. My redis.conf file was broken. As usual, at the end of the day redis error finds you ! Finally setup is done.

    My nodebb setup experience = Hey nodebb ! if you want to grow you have to support MySQL. It isn't important how fast redis is because it does not give confidence any time.

    Best Regards,


Log in to reply
 

Looks like your connection to NodeBB was lost, please wait while we try to reconnect.