Installation Errors



  • Installing on a KVM VM, Centos 6 64bit. Followed the tutorial https://docs.nodebb.org/en/latest/installing/os/centos.html

    Getting errors though...

    [root@localhost ~]# curl https://raw.githubusercontent.com/creationix/nvm/v0.13.1/install.sh | bash
    source ~/.bash_profile  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
    								 Dload  Upload   Total   Spent    Left  Speed
    101  3442  101  3442    0     0  16694      0 --:--:-- --:--:-- --:--:-- 98342
    => Downloading nvm from git to '/root/.nvm'
    => Initialized empty Git repository in /root/.nvm/.git/
    remote: Counting objects: 5491, done.
    remote: Compressing objects: 100% (7/7), done.
    Receiving objects: 100% (5491/5491), 1.58 MiB, done.
    remote: Total 5491 (delta 0), reused 0 (delta 0), pack-reused 5484
    Resolving deltas: 100% (3321/3321), done.
    Note: checking out 'v0.13.1'.
    
    You are in 'detached HEAD' state. You can look around, make experimental
    changes and commit them, and you can discard any commits you make in this
    state without impacting any branches by performing another checkout.
    
    If you want to create a new branch to retain commits you create, you may
    do so (now or later) by using -b with the checkout command again. Example:
    
      git checkout -b new_branch_name
    
    HEAD is now at eef12cc... v0.13.1
    Deleted branch master (was f9e14b7).
    
    => Appending source string to /root/.bash_profile
    => Close and reopen your terminal to start using nvm
    [root@localhost ~]# source ~/.bash_profile
    /usr/bin/which: no node in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin:/root/bin)
    
    [root@localhost ~]# nvm install v0.12.7 # as of this writing check the result of the list-remote to see all choices
    ######################################################################## 100.0%
    -bash: manpath: command not found
    Now using node v0.12.7
    [root@localhost ~]# systemctl start redis
    -bash: systemctl: command not found
    [root@localhost ~]# 
    [root@localhost ~]# systemctl enable redis
    -bash: systemctl: command not found'

Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.