Clicking on @username goes to localhost:4567



  • On my nodebb when I click on a @username link it goes to localhost. localhost:4567/uid/12.

    How can I fix this problem?


  • GNU/Linux

    Check the url option within the config.json.
    It must be set to the address to access your forum from the outside world.



  • @frissdiegurke said in Clicking on @username goes to localhost:4567:

    It must be set to the address to access your forum from the outside world.

    Can i do this in admin panel?
    Because I never been into config.json and it always worked well since yesterday.


  • Gamers

    @MJ access trough FTP (filezilla for example), es easy, same user, same pass from ssh and:

    First: Shout Down your nodebb, then

    alt text

    and edit:

    alt text

    Upload the modified config.json and start nodebb


  • GNU/Linux

    You can't do this via ACP.
    It has to be changed within config.json, which got filled with your values during the ./nodebb setup step.

    It probably never worked that well. The problem is that the url option is only used very rarely. It's for example used for links within emails, etc. and does not break the main application if set incorrectly.
    I assume this is just the first time you notice it ;)



  • @frissdiegurke Im 100% sure it works and i only change things in admin.

    Also search option gives an error.

    Thanks for the explain. I Will do it tonight.



  • Btw on Mobile phone on this site i get massage my post is spam by askimrt or something. When i do it Again my post is placed.


Log in to reply
 

Looks like your connection to NodeBB was lost, please wait while we try to reconnect.