Unable to login after upgrade to the latest version



  • Hello,

    I am running nodebb on my own debian jessie. After upgrading to 1.1.0 I am unable to login. I am getting:

    31/7 19:00 [14894] - error: /comments/login
     invalid csrf token
    

    I have did whatever I was doing before to get rid about this error but this time they are not working. Please help me figure out what's wrong.

    Regards.
    Peter



  • @Peter-Zoltan-Keresztes WOW, really no fix no nothing?



  • Every time I try to login to my nodebb I am getting the following error:

    and in the console I can see this:

    4/8 20:56 [26570] - error: /comments/login
     invalid csrf token
    

    I have tried clearing the caching of my browser. I even tried logging in from systems from where I never accessed the nodebb ever I am still getting the exact same thing.

    Since I am not getting any help in fixing this is there a way to revert it back to the last older version which was known to work fine? Like 1.0.3?

    I hope I will be getting some information this time.

    Regards,
    Peter


  • Admin

    Hey there, sorry we missed this.

    Please consult the nginx config doc for NodeBB and ensure that you are passing in the X-Forwarded-Proto header. It is new :smile:

    That should fix it right up for you.



  • @julian I by mistake found another post related to this and managed to fix it. Thanks anyways.

    By the way the blog comment plugin is disabled or not supported anymore? After I upgraded it seam to be completely disabled from my ghost blog.


  • Admin

    @Peter-Zoltan-Keresztes Not to my knowledge... we're still using it here on this site :worried:

    Perhaps ping @psychobunny ...?


Log in to reply
 

Looks like your connection to NodeBB was lost, please wait while we try to reconnect.