MongoDB version mismatch



  • Hi there,

    I just did a fresh build of nodebb v1.1.0 and it would not start because mongodb@2.1.22-alpha4 had been pulled in automatically.

    I was able to fix my install by manually installing mongodb@2.1.3 but obviously this isn't ideal.

    P.S. The build of the older version of mongodb failed, but it didn't matter in my case since I'm using redis.

    make: Entering directory `/usr/src/NodeBB-1.1.0/node_modules/mongodb/node_modules/kerberos/build'
    CXX(target) Release/obj.target/kerberos/lib/kerberos.o
    In file included from ../lib/kerberos.cc:1:0:
    ../lib/kerberos.h:5:27: fatal error: gssapi/gssapi.h: No such file or directory
    #include <gssapi/gssapi.h>

    Regards, Dave.


Log in to reply
 


Looks like your connection to NodeBB was lost, please wait while we try to reconnect.